Texas Tech University.
TTU Home IT Division IT Help Central

Internet Explorer 8 Compatibility with TTU Systems

NOTE: This announcment is no longer current and has been maintained only for archival purposes.

Beginning in April 2009, Windows PCs began receiving Microsoft Internet Explorer Version 8 (IE8) as a high priority Windows update.  Currently, the update is a user selectable option and is not installed automatically.

Microsoft states that IE8 has more advanced security features than its previous versions.  However, due to compatibility issues, TTU enterprise application vendors have not yet certified the use of IE8.  Therefore, if you use TTU enterprise applications we advise you not to install the IE8 update.

These enterprise applications include:

Compatibility View

Although not officially supported by the vendors, some TTU enterprise applications may function normally under IE8 with the following adjustments to your IE8 settings.

Some Web sites may not be ready for Internet Explorer 8.  Click the Compatibility View button to display the Web site as viewed in Internet Explorer 7.  This will correct display problems like misaligned text, images, or text boxes.

          

NOTE:  This option is on a per site basis and all other sites will continue to display with Internet Explorer 8 functionality.  To go back to browsing with Internet Explorer 8 functionality on that site, simply click the Compatibility View button again.

Accessing TechBuy with Internet Explorer 8

If you receive an error in TechBuy when choosing Punchouts in Internet Explorer 8, you will need to disable a feature before continuing use.  Please click here to view instructions.