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Introduction 

SAS Enterprise Guide (EG) is a project-oriented Windows application designed to be 

used by business analysts, statisticians, and programmers.  It can be used for 

exporting data and results to other applications and creating reports, queries, and 

charts. 

 

For this course, it is assumed that you have completed the Base SAS ShortCourse or 

already know how to create SAS data sets.  Also, familiarity is assumed with 

Elementary Statistics and Microsoft Access Queries.  We will be using 3 sample data 

files (included with SAS Enterprise Guide): Orders.sd2, PRDSALE.sas7bdat, 

Products.sas7bdat, and FixWidth.txt, throughout this ShortCourse. 

 

Course Objectives 

After completing this ShortCourse, you should be able to: 

• Create and save SAS projects,  

• Add SAS and Microsoft Excel data to a project,  

• Import data from a text file,  

• Create and modify a list report,  

• Create charts, 

• Use a query to join tables,  

• Use a query to select, order, create computed columns, and   

• Generate summary statistics from a query.  

• Combine several HTML results from multiple tasks into a single document. 

 

Starting a New Project 

• From the Start menu choose Programs 

• Select SAS 
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• Click on Enterprise Guide 4.1. 

• In the Welcome to SAS Enterprise Guide window, click New Project.  

 

Saving a Project 

• From the File menu, select Save Project As.  

• Select a location for your project. 

• In the File name box, type a name for your project. (Project files are saved with 

the extension .egp.)  

• Click Save.  

 

Enterprise Guide Help 

• Select Help > SAS Enterprise Guide Help. 

• On Contents tab, double-click the book icons to display the help topics. 

 

Enterprise Guide Main Windows 

 

The Process Flow 
displays the 
objects in your 
project and the 
relationship 
between objects. 

The Task Status window is to monitor 
processing of codes and tasks. 

The Task List is to 
select and open tools 
and tasks.  You can 

open the Task List by 
clicking this button. 

The Project 
Explorer 

enables you 
to access and 
manage data, 
tasks, code, 
and results 

with a 
hierarchical 
view of your 

project. 
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• SAS Enterprise Guide windows include the Project Explorer, Project Designer, 

Task List (View > Task List), and Task Status windows. SAS Enterprise Guide 

Tasks generate SAS codes and formatted results for you.  They include SAS 

procedures. 

• Task Roles are procedures we assign to variables. 

 

Project Explorer Window 

• A project is a collection of related data, tasks, code, and results.  

• By default Data entries, Tasks, and Codes are grouped together in a project. 

• If you close the Project window and want to restore it, select View > Project 

Explorer.  
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Process Flow Window 

• The Project Designer window displays the items in a project and the relationship 

between the items.  

• As you add data, run tasks, and generate output, the process flow of your work is 

automatically displayed in the Project Designer window. 

• You can have multiple process flow diagrams for one project. 

• To view the Process Designer window: 

• Select View, and then choose Project Designer. 

 

 

Task List 

• A task is a specific analysis that you can perform or a report that you can create 

from your data.  

• To begin a task, first select the data that you want to use, and then click the task 

in the Task List.  

• The Task List has two views (tabs) at the top of the window. 

• The Tasks by Category tab lists individual tasks, grouped by type. 

• The Tasks by Name tab lists individual tasks alphabetically. This tab also lists 

the SAS procedure or procedures that are related to the task.  

• To view the Task List, click the Task List tool     on the toolbar or select 

View > Task List.  

• The tasks that are available in the Task List are also available from the Data, 

Describe, Graph, and Analyze menus.  
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Task Status Window 

• The Task Status window displays messages about the status of tasks as they 

process.  

• The Process Flow window also displays a different background color around the 

task item for each phase of processing. 

 

Data in SAS Enterprise Guide 

• SAS Enterprise Guide requires all data that it accesses to be in table format. A 

table is a rectangular arrangement of rows and columns.  

• Rows (also called observations) in a table are collections of data values related 

to an object. 

• Columns (also called variables) in a table are collections of values that describe 

a characteristic.  

 

Column (Variable) Properties 

• Name - can be 1 to 32 characters long. They must begin with a letter (A-Z, 

either uppercase or lowercase) or an underscore ( _ ). They can continue with 

any combination of numbers, letters, or underscores, but NO space. 

• Type - is either character or numeric.  

• Character variables can contain any values. Missing character values are 

represented by a blank.   

• Numeric variables can contain only numeric values (the digits 0 through 9, 

+, -, . ,  and E for scientific notation).  

• Currency, date, and time data are stored as numeric variables. 

• Missing numeric values are represented by a period.  

• Length - A column’s length (the number of bytes that are used to store it) is 

related to its type.  

• Character variables have a default length of 12 bytes. 

• All numeric variables have a default length of 8 bytes.  

• Format - affects how data values are displayed. SAS data formats include 

character, numeric, and date and time.  

• Informat - determines how data values are read into a SAS data set. You must 

use informats to read numeric values that contain letters or other special 

characters.  
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• Label - A variable can have a label, which consists of descriptive text up to 256 

characters in length.  

 

Creating a New Data Set 

• Select File > New > Data.  

• Name your Data, select a location and click Next>. 

• Select and Change column Name A to ID 

• Change this column’s Label to Student ID (using the column properties) 

• Change this column’s data Type to Numeric.  

• Add the following column headings (variable names) to the table, selecting 

columns from the Columns List and changing their names and properties as 

specified: 

o Age   Numeric 

o Gender  Character 

o Major   Character 

o GPA   Numeric 

o School   Character 

• Click Finish 

• Type data from the following table into each cell in the grid by using the Tab or 

arrow keys to navigate around the grid.  (you can Copy & Paste data, one entry 

at a time)  

• Delete unused rows and columns. 

• Close this new data window.  

 

 
ID Age Gender Major GPA School 

1 19 male biol 4 Smith 

2 18 female biol 3.5 Smith 

3 20 male biol 3.8 Smith 

4 19 female soci 3.9 Smith 

5 18 female soci 4 Honey 

6 20 male soci 4 Honey 

7 18 male cs 2.9 Honey 

8 19 male cs 3.2 Honey 

9 20 female cs 3.6 Honey 

10 21 female math 3.8 Honey 
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To change the protection mode 

• Open your data set 

• Select Data > Read-only to toggle the Update mode on and off. You are 

prompted for confirmation when you change a file from Read-only mode to 

update mode.  

 

Assigning Task Roles 

• To create reports and run analyses on the data, you select tasks from the Task 

List, either sorted by category or alphabetically. Double-click a task name to 

begin using it.  

• A task is an analysis that you perform or a report that you create from your data.  

 

 

Creating a List Data 

• From the Describe menu, select List Data . . . 

• Shift-click on first and last variables names to select them all. 

• On the Task Roles tab, drag all the variables to the right and drop them under 

the List variables heading. 

• On the Options tab, uncheck mark Print the row number box. 

• On the Titles tab, uncheck mark the Use default text box. 

• Rename the Title to “Schools Report”. 

• Click the Preview Code. 

• Close the Preview Code window. 

• Click on the Run button to run the procedure to generate a report. 
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Changing the Report Style 

• From the Tools menu, select Options 

• On the Results tab, select HTML 

• Change the Appearance Style from EGDefault by selecting a different style sheet 

from the drop down menu (BarrettesBlue, for example), and then click OK. 

• Close the output window. 

• Choose Tools > Options > Results > Results General > Uncheck mark PDF and 

RTF. 

 

 

Calculating One-Way Frequencies 

• From the Describe menu, select One-way Frequencies 

• Shift-click on the variable names Age, Gender, and Major. 

• Drag the variables to the right, and drop them under the Analysis variables 

heading.  

• Click on the Run button. 

• Close the output window. 

 

Creating a Scatter Plot 

• From the Graphs menu, select Scatter Plot . . .  

• Select 2D Scatter Plot. 
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• Click the Task Roles tab. 

• Select Age for Horizontal and GPA for Vertical, and then drag them to the 

Scatter Plot Task Roles. 

• Click on the Run button. 

• Close the output window. 

 

Calculating Summery Statistics 

• From the Describe menu, select Summery Statistics . . .  

• Select GPA variable, and drag it to Analysis Variables. 

• Click on the Run button. 

• Close the output window. 

 

 

 

 

 

 

 

 

 

 

 

Local and Remote Data 

• When you open data in SAS Enterprise Guide, you must select whether you want 

to look for the data on your local computer or on a SAS server.  

• If you click Local Computer, a window opens so that you can browse the 

directory structure of your computer. You can open any type of data file that SAS 

Enterprise Guide can read.  

• If you click SAS Servers, you can look for your data on a server. A SAS server 

can either be a local server if SAS software is installed on your own computer, or 

it can be a remote server if SAS software is installed on a different computer. The 

servers that you see depend on what repository you are connected to.  

• Within each server there are icons that you can select for Libraries and Files. 

Libraries are shortcut names for directory locations that SAS knows about. Some 
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libraries are defined by SAS, and some are defined by SAS Enterprise Guide. 

Libraries contain only SAS data sets.  

 

Sample Data Sets 

In the SAS Enterprise Guide sample data directory there are four data files that 

contain data from a specialty foods store: 

• Orders - a SAS data set that has data for product sales 

• Products - a SAS data set that has data for products 

• PRDSALE - a SAS data set  

• SupplyInfo - a Microsoft Excel data file that has data for product suppliers 

• FixWidth - a text file that has data for product categories.   

 

Adding SAS Sample Data Sets 

• From the File menu click Open > Data. 

• Select Local Computer… 

• Double-click Enterprise Guide Sample, and then double-click Data.  

• Press CTRL and select Orders.sd2, Prdsale.sas7bdat, and 

Products.sas7bdat files, and then click Open.  

• Close all data table windows. 

 

Importing Excel Data File 

• From the File menu, select open > Data.  

• Choose Local Computer… 

• Double-click the SupplyInfo.xls file.  

• Select the SAS data option to open this file. 

• Click the Run button. 

• Close the data table window. 

 

Importing SAS Sample Text Data 

• From the File menu, select Import Data. Select Local Computer… 

• Double-click FixWidth.txt.  

• In the Region to import, click Text Format, be sure Fixed Width is selected.  

• In the Region to import, click Column Options. 

• In the Columns list, select CategoryID. Under Column Properties, click Label 

and change it to Category ID.  
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• In the Columns list, select CategoryName. Under Column Properties, click 

Label and change the label to Product Category.  

• In the Columns list, select Description.  

• Under Column Properties, click Include in output and select No from the 

drop-down list.  

• In the selection pane, click Results. To Specify a name and a location for the 

table, In the Import Data task window, click the Browse… button (By default, the 

table is saved to your SASUSER library. ) 

• In the File name box, type Categories, and then click Save. 

• Click Run.  

• Close the data window. 

 

Creating Summary Statistics 

• In the Project Explorer, click the PRDSALE table to make it the active data.  

• You can also specify the active data by selecting it from the Active Data drop-

down list directly above the Project Explorer. 

• In the Task List window, scroll down to the Describe category.  

• Click the Summary Statistics task.  

• Press CTRL and select PRODUCT, ACTUAL, PREDICT columns in the Variables box. 

• Drag the selected variables to the List variables role. 

• In the List variables role, select Month and drag it to Classification Task roles and 

select YEAR and drag it to Group Analysis by Task roles.  

• Click Run. 

• Close the output window. 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2006 Heide Mansouri   
Texas Tech University  Updated: 10/19/2006 

11



SAS Enterprise Guide SC 

Creating Charts 

• In the Project Explorer window, select Products to make it the active data set. 

• From the Graph menu, select Bar Chart.  

• Click the Vertical Colored Bars icon.  

• In the selection pane, click Task Roles. In the Columns to assign list, select 

CategoryID, and drag it to the Column to chart role.  

• Select UnitsInStock, and drag it to the Sum of role.  

• Click Run to create the graph. 

• Right-click on any bars. 

• Select Bar options…, and then select Color by Category. 

• Click OK.  

• Double-click the HTML - Bar Chart item in the Process Flow window to view the 

chart. 

 

 

 

Queries 

A query is a request to retrieve data from one or more data sources (tables).  Using 

queries, you can  

• Join Tables 

• Group and Summarize Data  

• Classify data into groups based on the values in a column.  

• Perform summary functions on any of the columns in your query.  

• Examine relationships between data values  
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• Subset and sort your data  

• Compute values 

• Group and summarize data.  

 

Queries 

A query is a request to retrieve data from one or more data sources (tables).  Using 

queries, you can 

 Join Tables 

 Group and Summarize Data  

 Classify data into groups based on the values in a column.  

 Perform summary functions on any of the columns in your query.  

 Examine relationships between data values  

 Subset and sort your data  

 Compute values 

 Group and summarize data.  

 

Creating Queries Using the Query Builder 

• On the Project Explorer window, select the Products table. 

• Select Data > Filter and Query … 

• On the Select Data tab, click on ProductName drag it to the Select Data window 

• On the Filter Data tab, Select the UnitsInStock and drag it to the Filter Data 

window 

• Change the operator to “Greater than”. 

• Type “0” for the Value to create Products.UnitsInStock > 0 expression  

• Click the Sort Data tab 

• Sort the UnitPrice > Descending 

• Click RUN.  
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Exporting the Query Results 

• Right-click on the query results data node. 

• Select Send to, and then choose Microsoft Excel. 

 

Creating a Query by Joining Tables 

• On the Project Explorer window, click on Products data set to make it active. 

• From the Data menu, select  Filter and Query … 

• In the Query Builder window, click on the Add Data… button 

• In the Open Data window, click Project. 

• In the Add from Project window, select SASUSER > CATEGORIES data set. 

• Click OK. 

• Click the join icon to see the variable that joins the two tables. The Products and 

Categories tables are joined on the CategoryID variable.  

• Close the Tables and joins window. 

 

 

 

 Manual join 

• In the Query Builder, click Add Tables.  

• In the Open Data window, click Project.  
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• Select Orders table and click OK to add it to the query. Because no column 

name and type matches are found, a message window alerts you that you will 

have to manually join the tables. In the message window, click OK.  

• Although the column names are different, the values in the ProductID and 

PRODID columns are related and have same data types. You can join the 

Products and Orders tables on these columns.  

• Click the ProductID column and drag the cursor to the PRODID column.  

• Close the Tables and joins window. 

 

 

  

Sorting 

• In the Query Builder window, click the Sort Data tab.  

• Double-click ProductName and then double-click UnitsInStock to add the two 

columns to the query.  

• From the list of columns for the Categories table, double-click CategoryName to 

add it to the query. 

• Click CategoryName and then click Move Up to move it so that it's the first 

column in the report. 
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Creating a Computed Column and Calculating the Profit 

• In the Query Builder window, click the Computed columns. 

• Click Build Expression… from the drop-down menu. 

• In the Advanced Expression Editor, click the Data tab, click Products. 

• In the Variable values box, double-click UnitPrice and use the operators and 

other variable values to complete the expression: 

                         (Products.UnitPrice - Orders.UPRICE) * Orders.QUANTIT 

• Click OK.  

• Click Run.  

• In the Computed columns window, select Calculation1 and click Rename 

• Type Total Profit, and press the Enter key. 

• Select the Total Profit and click the Properties button to format it to Currency 

and DOLLARw.d 

• Double-click the Total Profit to add it to the Query 

• Click Run 

• Close the query. 

 

 

Generating Summary Tables from a Query 

• In the Project Explorer, select Query_for_Products output data to make it 

active. 

• Select Describe > Wizards > Summary Tables … (the default sum is selected 

for the statistic). 
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• Click Next > 

• Click Add and select Total Profit variable. 

• Click Add and select Total Profit variable again. 

• Select Average from the Statistic drop-down list. 

• Click Add and Select Total Profit variable again. 

• Select % of Column Sum from the Statistic drop-down list. 

• Click Next. 

• In the Rows section, click Add and select CategoryName 

• In the Rows section, click Add and select ProductName 

• Look at the preview area to see the layout of your report 

• Click Next. 

• Click the Rows, and select Totals at Each level. 

• Click Next. 

• In the Table Title, type : Profit By Products 

• Delete the Footnote. 

• Click Finish. 

• Close the Output window. 

 

 

 

Creating a Pie Chart 

• In the Project Explorer, select Query_For_Products output to make it active.  

• From the Graph menu, select Pie Chart. 

• In the Pie Chart gallery, select the Simple Pie icon.  

• In the selection pane, click Task Roles. 
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• Assign the CategoryName column to the Column to chart role.  

• Assign the Profit column to the Sum of role.  

  

Pie Chart Options 

• In the selection pane, click Layout. 

• In the drop-down lists for Name, Percentage, and Statistic Value, select 

Outside.  

• In the selection pane, click Titles. 

• For the graph, clear the Use default text check box, and type Profit by 

Product Category. 

• Click on the Run button.  

• View the pie chart, and then close any open windows in the workspace.  

 

 

 

Using SAS Document Builder  

The Document Builder enables you to combine the HTML results from multiple tasks 

in your project into a single document. 

• Select Tools > Create HTML Document 

• In the HTML Title box, type: Profit Report 

• Click Add > choose Task Result from the Add menu 

• In the Add Results window, press CTRL, and select Summary Tables and Pie 

Chart 

• Click OK 

• In the Document Builder, select Pie Chart and click UP 

• On the Options tab, choose a style for the document (sasweb for example). 
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• Make your selection for the Table of Contents option. 

• Click Preview 

• Close the HTML Report 

• Click OK. 

Note: You can e-mail your document by right-clicking the report, and then select 

Send To.  

 

Online References 

• Documentation 

http://www.sas.com/technologies/bi/query_reporting/guide/index.html    

• Enterprise Guide Users’ Group 

     http://www.bisug.org   

 

Book Reference 

• Getting Started with Enterprise Guide, 2nd edition, 2002, SAS Publishing. 

• The Little SAS Book for Enterprise Guide 3.0, Susan J. Slaughter and Lora D. 

Delwiche , Dec. 2005 

 

Where to Get Help 

• If you need help with your project, you may contact Help Central at 742-HELP.  

• If you need help from your instructor, you may e-mail heide.mansouri@ttu.edu.  

 
Please e-mail your comments or suggestions to: heide.mansouri@ttu.edu  
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