Objectives
After completing this course, you should be able to:
• Explain the basic tools of Dreamweaver;
• Know general forms of Web page layouts;
• Use these tools and knowledge to develop a basic Web page;
• Incorporate Flash within your site; and
• Learn how to upload your page on the Internet.

Course Topics:
• Application Layout
• Basic Text Options
• Images
• Getting Started
• Defining Page Layout
• Using Flash
• Publishing, Maintaining, and Correcting

Application Layout
• Views
  o Code
  o Design
  o Code and Design
• Object Panel
  o Holds common objects
  o Can change type of objects
• Work area
  o Where site is designed
• Properties Panel
  o Holds properties for a selected object
These windows are Web document files that have been opened and panels with information and tools that you can use.

**Work Area**

The work area is a Document window with a toolbar at the top. It shows the current document approximately as it appears in a Web browser.

The different View modes are listed on the toolbar, followed by the title of the active document. This is also shown in the title bar of the window. You can update and change a Web page's title here. Other options include File Management, Preview, and Design Refresh.

**View Modes**

There are three different view modes in the work area.
You can switch between View modes by clicking one of the **View buttons** in the upper-left corner of the work area document or by using the **View menu**.

**Code View**

```html
1. <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
2. "http://www.w3.org/TR/html4/loose.dtd">
3. <html>
4. <head>
5. <title>Untitled Document</title>
6. <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
7. </head>
8. <body>
9. Hello World!!!
10. </body>
11. </html>
```

This is a basic HTML editor. If you would like to edit the HTML directly, use the Code view.
Any scripts such as JavaScript, VBScript, or PHP must be entered in the Code view.

**Design View**

Hello World!!!

Design view is the WYSIWYG editor. It shows approximately what your Web page will look like in a standard browser.
You never have to look at the HTML code in this view.
Both Views

This option gives you the best of both worlds. It shows the Code view on the top half of the work area and the Design view on the bottom half. Changes made in the design half will be shown immediately on the Code view, but changes in the code will only show up in Design view after you click in the Design view half of the screen or select Refresh.

Panels

Dreamweaver separates different tools and functions into different Panels on the screen. The two panels you will probably use most are the Objects Panel and the Properties Panel.

Objects Panel

The Objects panel contains buttons for creating and inserting objects such as tables, layers, and images. It contains seven categories: Common, Layout, Forms, Text, HTML, Application, Flash Elements, and Favorites. The different categories can be accessed by clicking on the category name at the top of the Objects panel.

Object Panel Tools

- Common
  - Insert Hyperlink
  - Insert Email Link
  - Insert Named Anchor
  - Insert Table
  - Insert Image
  - Insert Media
  - Insert Date
  - Insert Comments
  - Insert Templates
  - Tag Chooser

Hello World!!!
• Layout
  o Draw Table
  o Insert Div Tag
  o Draw Layer
  o Insert Rows
  o Insert Columns
  o Insert Frames
  o Insert Tabular Data
• Forms
  o Insert Form
  o Insert Text Field
  o Insert Hidden Field
  o Insert Text area
  o Insert Checkbox
  o Insert Radio Button
  o Insert Radio Group
  o Insert List/Menu
  o Insert Jump Menu
  o Insert Image Field
  o Insert File Field
  o Insert Button
  o Insert Label
  o Insert Fieldset
• Text
  o Font Tag Editor
  o Bold
  o Italics
  o Strong
  o Emphasis
  o Other formatting options
• HTML
  o Horizontal Rule
  o Insert Head
  o Insert Tables
  o Insert Frames
  o Insert Scripts
• Application
  o Insert Recordset
  o Insert Stored Procedure
  o Insert Dynamic Data
  o Insert Repeated Region
  o Insert Master Detail Page
  o Insert Record
  o Update Record
  o Delete Record
  o User Authentication
• Flash Elements  
  o Insert Flash Button  
  o Insert Flash  
  o Insert a Flash Movie  
  o Insert Flash Text  

Properties Panel

The Property panel (or Property inspector) lets you examine and edit properties for the currently selected page element. (A page element is an object or text.) You can select an element simply by clicking on it once. The contents of the Property panel vary depending on the element selected.

Tag Selector

The tag selector is located in the bottom-left corner of the Document window. It displays the HTML parent tags that control selected text or objects. Click one of these tags to highlight its contents in the Document window.

Text Options

• Adjust Properties using the properties panel  
  o You can change size, color, and style and add bullets, align, and add hyperlinks all within the properties box

Images

• Inserting Images  
  o Choose Insert ➔ Image, or click the Insert Image button from the objects panel.  
  o Browse to select the image you want to insert into your page.  
• Rollover Images  
  o Choose Insert ➔ Image Objects ➔ Rollover Image, or click the Rollover shortcut on the objects panel.  
• If you want to use the image as a link, insert the Web address within the Link box in Properties panel.
Getting Started
• Creating a Site
One of the first things to do when beginning a site with Dreamweaver is to create a local Site Definition on your machine. Setting up this local site in Dreamweaver means that you can use Dreamweaver with FTP to upload your site to a Web server, automatically track and maintain your links, and collaboratively share files.

To create a new site:

1. Follow the wizard to setup your site.
2. Choose Site → New Site.
   In the Site Definition dialog box that appears, the Local Info category is selected.
   • Site Name – a name for your reference; it will not appear in the browser.
   • Local Root Folder – this is where your files are stored on your computer.
   • HTTP Address – this is the URL that your completed Web site will use. It can be left blank.
3. Select Remote Info from the Category list.
   Choose from the Server options:
   ➢ None – if you do not plan to upload your Web site to a server
   ➢ FTP – to connect to your server through FTP
     • FTP host name – full Internet name of a computer system; for TTU's Information Technology Personal Web Pages, you would enter: webpages.acs.ttu.edu
     • Host Directory – where your files will be stored on the server; often this is public_html/
     • Log in name and password – The name and password you need to connect to the server; for your TTU personal Web page, this is your eRaider username and password.
4. Click OK.
5. Go to Windows and Choose Files.
6. The **Site Files** window will show up as a panel. You can choose to view your local files or the remote view if you have setup your remote server. Note that your Site Name appears at the top of the window.

Working with Documents

Web documents are what make up a Web site. To create a new document: Choose **File ➔ New**

**Page Properties**

Page titles, background images and colors, text and link colors, and margins are basic properties of every HTML document. You can modify these in **Page Properties**.

To view Page Properties:

- Choose **Modify ➔ Page Properties**, or

You can modify the basic properties here.

- **Title** – identifies and names the document.
• **Background image or color** – sets the overall appearance of the document.
• **Text and Link colors** – help site visitors distinguish regular text from hypertext and to see which links have been visited and which have not.

**Text**
A Web document is made up of many elements, including text. Text can be entered into your document simply by typing.

**Note:** The ENTER key works differently in Dreamweaver than it would in other text editors (such as MS Word). When you press ENTER in an HTML document, it creates a new paragraph, leaving a blank space between. To leave out this blank space, press SHIFT-ENTER to insert a line-break instead of a new paragraph.

**Modifying Text**
Dreamweaver allows you to modify text in many different ways using the Properties panel.

![Properties Panel](image)

**Fonts**
You can change the font of your text in Dreamweaver by selecting the text, and then choosing one of the Font lists in the Properties panel. HTML uses Font-Stacking in naming fonts for text. This means that a Web browser will look for the first font listed on a user’s computer, but, if it does not find it, it will look for the next on the list, and so on. It is recommended to use one of Dreamweaver’s default font-stacks (the different choices in the Font list menu) in order for your page to look as intended on most user computers.

**Effects**
The Properties panel lets you easily change text size, color, and other appearance.

1. Select the text you want to modify.
2. To:
   - **Change the size of your text**  
     • Click the double arrows next to the size text-box and choose a value, or
     • Type in the HTML font-size value you would like.
   - **Change the color**  
     • Click the colored box, and click a color from the swatches or anywhere on the screen, or
     • Type in the HTML HEX color code in the color text-box.
   - **Bold or Italics**  
     • Click the appropriate button.
Change the Paragraph Alignment

- Click the Left Paragraph (default), Centered, or Right button.

**Links**

There are three basic types of links in HTML: external site, internal site, and internal page.

To create a link:

1. Select the text to be the link.
2. Type in the link destination in the Properties panel, or
   - Click the folder to select the filename (internal),
   - Use the target to drag to a file in your site (internal).

**External Site Links**

External site links are links that go to a Web site away from your own site, such as Yahoo or Texas Tech. These sites are often not under your control.

To create an external site link:

1. Select the text to be the link.
2. Type in the complete Web address (including the http://) of the external site in the Properties panel link box.

**ex: http://www.ttu.edu/**

**Internal Site Links**

Internal site links connect to another page within your Web site.

To create an internal site link:

1. Select the text to be the link.
2. Type in the file name of the Web document to link to in the Properties panel link box, or
   - Click the folder to select the file name,
   - Use the target to drag to a file in your site.

**ex: links.html**

**Internal Page Links**

Internal page links connect to a specific place within a page in your Web site. This can be on the same page as the link or on a different page.

Internal page links are accomplished using **named anchors** at the position to which to connect. Named anchors are similar to bookmarks. They give a specific point on a Web page a name in order to allow links to "jump" to that portion of the page.
To insert a named anchor:

1. Position the cursor at the point where you want to place the named anchor.
2. Choose **Insert** → **Named Anchor**.
3. In the **Anchor Name** box, type a name for the anchor.
   This can be anything you like.

To insert an internal page link:

1. Select the text to be the link.
2. Type in the filename of the Web document to link to, followed by a # and the anchor name.

   ➢ ex:  links.html#fun

**Lists**

Dreamweaver allows you a quick and easy way to create lists from text. There are three basic types of lists: ordered and unordered. The easiest way to create one of these lists is to use the Properties panel.

**Ordered Lists**

Ordered lists are numbered or lettered lists. This type of list is also used for creating outlines.

To create an ordered list:

1. Select the line(s) of text to be in the list.
2. Click the **Ordered list button** in the Properties panel.

To indent a list item (for outlines):

1. Position the cursor in the list item to indent.
2. Click the **Text Indent button** on the Properties panel.

**Unordered Lists**

Unordered lists are bulleted lists.

To create an unordered list:

1. Select the line(s) of text to be in the list.
2. Click the **Unordered list** button in the Properties panel.

## Tables

Tables are an extremely powerful tool for laying out data and images on an HTML page. Tables provide Web designers ways to add vertical and horizontal structure to a page. Tables consist of three basic components:

- **Rows** (horizontal spacing)
- **Columns** (vertical spacing)
- **Cells** (the container created when a row and column intersect)

Use tables to lay out tabular data, to design columns on a page, or to lay out text and graphics on a Web page. Once you create a table, you can easily modify both the appearance and the structure of the table. You can add content; add, delete, split, and merge rows and columns; modify table, row, or cell properties to add color and alignment; and copy and paste cells.

To insert a table:

1. Place the cursor where you want the table to appear.
2. Click the **Insert Table button** on the Objects panel.
3. In the Insert Table dialog box, accept the current values or type new values.

- **Rows** – number of table rows
- **Columns** – number of table columns
- **Cell Padding** – the number of pixels between the cell content and the cell boundary. The default padding is 1 pixel. Enter 0 for no padding.
- **Cell Spacing** – the number of pixels between each table cell. The default spacing is 2 pixels. Enter 0 for no spacing.
• **Width** – the width of the table as a number of pixels or as a percentage of the browser window
• **Border** – the pixel width of the table border. Enter 0 if you don’t want a border.

4. Click OK.

**Column Width**

When you first create a table, all the columns are created as the same width. To change a column width:

1. Click in any of the column’s cells, or select the column.
2. In the **W field** of the Properties panel do one of the following:

   • Enter a number to set the column width to the specified number of pixels.
   • Enter a number followed by the % symbol to set the column width to a percentage of the table width.
   • Leave the field blank (default) to let the browser and Dreamweaver determine the proper width based on the contents of the cell and the widths of the other columns.

   or

   1. Move the mouse over one of the vertical column walls.
   2. Click and drag until the width is approximately where you want it.

**Pixels vs. Percentages**

Dreamweaver gives you the option to set table and cell widths in either pixels or percentages.

• **Pixels** – sets the width to a defined size; no matter what the size of the browser window, the width will always be the same.

• **Percentage** – sets the width to a percentage of the browser window; as the window changes size, the positions and widths of elements will adjust. This is good to keep more information on the screen without the user having to scroll horizontally. However, the page may not look exactly as intended.

**Layout Mode: Tables and Cells**

• Layout Mode enables you to create custom table sizes as well as create custom table cells.

• This is one of the many powerful tools Dreamweaver has compared to other code generators such as Front Page.

**Drawing Tables in Layout View**

• Choose Layout View from the Objects panel.

• Choose Draw Layout Table from the Objects panel.
• Click and drag to create table size.
• Choose Draw Layout Cell from the Objects panel.
• Click and drag inside the layout table to create new cell.

Images
Three graphic file formats are generally used in Web pages – GIF, JPEG, and PNG. Only GIF and JPEG are fully supported by most browsers. Unless you are targeting your site to users with browsers that support the PNG format, use GIFs or JPEGs for broader appeal.

Inserting Images
To insert an image:

1. Place the insertion point where you want the image to appear.
2. Click the Insert Image button on the Objects panel.
3. In the Insert Image dialog box that appears, click Browse to choose a file, or type the path for the image file.
4. Use the Properties panel to adjust the image properties.

Inserting Rollover Images
A rollover is an image that changes when the pointer moves across it. A rollover actually consists of two images: the primary image (the image displayed when the page first loads) and the rollover image (the image that appears when the pointer moves over the primary image).
Both images in a rollover should be the same size; if the images are not the same size, Dreamweaver automatically resizes the second image to match the properties of the first image.
To create a rollover:

1. Place the cursor where you want the rollover to appear.
2. Click the **Insert Rollover Image** button in the Objects panel.
3. In the Insert Rollover Image dialog box, insert the following information:

   ![Insert Rollover Image dialog box](image)

   - **Image Name** – a name for the rollover image; this can be anything; it is used "behind-the-scenes."
   - **Original Image** – click Browse, and select the image or type the path of the image you want displayed when the page loads.
   - **Rollover Image** – click Browse, and select the image or type the path of the image you want displayed when the pointer rolls over the original image.
   - **When Clicked Go to URL** – click Browse, and select the file, or type the path to the file you want to open when a user clicks the rollover image.

   **Note:** If you don't set a link for the image, Dreamweaver inserts a null link (#) in the HTML source code to which the rollover behavior is attached. If you remove the null link, the rollover image will no longer work.

4. Click **OK**.

**Flash**

Flash is a Web-development tool used to create animations and user interactivity. Dreamweaver allows easy insertion of Flash objects into your Web page. Dreamweaver has many built-in Flash functions such as Flash Text, Flash Buttons, and even importing your own Flash movie.

**What are Flash objects?**

Flash objects are small graphic SWF (Shockwave) files you can create with the Flash program or from within Dreamweaver. Dreamweaver allows you to create Flash Text and Flash buttons, as well as insert existing Flash movies.

**Flash Text**

Flash Text allows you to design Web pages that use nonstandard fonts without worrying about which fonts visitors to your site have available on their computers.
• Gives the option of adding rollover capabilities as well as links and absolute fonts.
• Click insert flash text button on the objects panel.
• Declare Font type, size and two font colors.
  o One will be normal; the other will be its rollover color.
• Type your desired text.
  o You can make it a link.

• Target
  o Specifies where the link will open.

Flash Buttons
Flash buttons are created from Flash templates that ship with Dreamweaver. You can easily customize a template button and add it to your Web pages.
• Choose Insert Flash Button from the objects panel.
  o Select the Button type.
  o Select the Button text.
  o Link the button to its destination.
  o Give the button a name to be saved by.

Inserting a Flash Movie
• Once you create your own movie, you can insert it with the Insert Flash button on the objects panel.
• Make sure the file you insert has the extension .swf.
• You may then align it or change properties in reference to the Flash movie and the HTML Dreamweaver page.

Publishing
• In order to view your site, you must publish it on the Web.
• You can get Web space from TTU, geocities, and tripod for free.
• You can register a domain name (ex: www.yourname.com). Search for Web page hosting on the Internet (ex: www.avahost.net).
• FTP
  o Once you decide where to put it, you can upload files using the built-in FTP program in Dreamweaver.

FTP
• Open Site Files window…double-click the name of your site to open-site definition.
• Change the category from local info to remote info.
• **Access** …Select FTP.
• eRaider FTP host.
  o “webpages.acs.ttu.edu”
• The files on your computer will appear on the right, and the files on the server will appear on the left.
• You can use the Put and Get buttons to choose if you want to put files on the server or get the most current files if you are collecting data from the Web page.

Maintaining and Correcting
• In order to make changes to your site, you must make the change on your computer files first.
• Once you make changes to the files on the computer, FTP them back to the server.
• **VERY IMPORTANT:** Make sure the first file you send is named index or default; otherwise, you won’t be able to see your Web site.

Flash Text
To create a Flash Text object:
1. Place the cursor where you want to insert the Flash Text.
2. In the Object panel, click the **Insert Flash Text** button.
3. In the **Insert Flash Text** dialog box, set the properties of your Flash Text.
4. Click OK.

Flash Buttons
To create a Flash button:

1. Place the cursor where you want to insert the Flash button.
2. Click the **Insert Flash Button** in the Objects Panel.
3. The **Insert Flash Button** dialog box appears. Set the properties of your Flash button.

4. Click **OK**.

**Questions?**

Feel free to contact me:

[allen.young@ttu.edu](mailto:allen.young@ttu.edu)