Microsoft Excel Formulas
ShortCourse Handout

July 2004
Copyright © 2004 Heide Mansouri, Technology Support, Texas Tech University. ALL
RIGHTS RESERVED. Members of Texas Tech University or Texas Tech Health
Sciences Center may print and use this material for their personal use only. No part
of this material may be reproduced in any form without written permission from the
author.

Introduction
Excel provides over 434 predefined formulas called functions to help you quickly
setup simple and complex calculations. These functions can help you perform
statistical, financial, and mathematical calculations and analysis.

Course Objectives
After completing this shortcourse, you should be able to:

• Create a formula with several operators and cell references;
• Use the Insert function feature to enter formulas;
• Edit formulas;
• Use the PMT function;
• Create a conditional formula, using the IF function;
• Create and use range names in formulas.

Excel Formulas

• Formulas are equations that perform calculations on values in your
  worksheet.
• A formula starts with an equal sign (=).
• A formula can also contain any or all of the followings:
  o Functions,
  o References,
  o Operators (*, /, +, -)
  o Constants, for example =Sheet2!$A$1
Operators and Order of Operations

<table>
<thead>
<tr>
<th>Operators</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>( )</td>
<td>Parentheses (to change the order of evaluation)</td>
</tr>
<tr>
<td>: (colon)</td>
<td>Reference Operator</td>
</tr>
<tr>
<td>%</td>
<td>Percent</td>
</tr>
<tr>
<td>^</td>
<td>Exponential</td>
</tr>
<tr>
<td>* and /</td>
<td>Multiplication and Division</td>
</tr>
<tr>
<td>+ and -</td>
<td>Addition and Subtraction</td>
</tr>
</tbody>
</table>

Entering Formulas

- Click in a cell > type an equal sign (=).
- Type your formula > Press the Enter key.
- To Edit Formula:
  - Double-click on the cell, containing the formula;
  - Or click on the cell to make it active, and click into the formula bar.
  - Edit your formula.

Using Range References

- Click in a cell and type an equal sign (=);
- Type the name of a function;
- Type an open parenthesis;
- Click in the first cell in your range;
- Type a period (.) to mark the beginning of the range;
- Click in the last cell in your range;
- Press the Enter key to return your formula:
  - =sum(A1:A3) for example.

Note: You can use your mouse for your selection, by clicking + holding and dragging over your range, then pressing the Enter key.
You may also use the arrow keys to select your range.

Relative and Absolute Cell References

- A relative cell reference is the relative position of the cell to the active cell. When copied, the cell automatically will adjust to the position. For example, =A5.
- An absolute reference refers to a cell by its fixed position (contains constant). When copied will not change. For example, =$A$5.
Using Cell Reference on another Worksheet

- Click in a cell, and type an equal sign (=).
- Type the name of the worksheet, then exclamation mark (!) in front of the cell/range reference.
- For example, =sheet3!C5.

Understanding Errors

- #### in a cell.
  - This happens when the column is not wide enough to display the data.
- #Div/0!
  - This happens when the formula is trying to divide a number by zero or an empty cell.
- #Name?
  - This happens when formula is not entered correctly.
- #Value!
  - This happens when you use a textual value of a cell in your calculation.
- #REF!
  - This happens when the value in cell referenced in row is no longer available in the formula.

Functions

- Functions are predefined formulas that perform calculations by using values called arguments.
- You use functions to setup simple and complex calculations quickly.
- Some of the most commonly used functions are included in the AutoSum drop down.
- To enter a function:
  - Click in a cell.
  - Type (=) sign.
  - Enter the function name, followed by an open parenthesis, followed by the range, then a close parenthesis.
  - Press the Enter key.
  - Example: =Sum(A1:A8)
Statistical Functions

- Average
- Count
- CountA
- CountIF
- Max
- Min
- Median
- Mean

Using IF Statement to Create Conditional Formulas

- Click in a cell, and click Insert > Function.
- Select IF from the list, and click OK.
- Type your statement in the Logical-Test text box.
- Click OK.
- Copy the formula to other cells.

Some Financial Functions

- FV – calculates the future value of an investment.
- IPMT – calculates the interest payment.
- NPV – calculates net present value of an investment.
- PMT – calculates the monthly payment of a loan.

Some Mathematical Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABC</td>
<td>=ABC (number)</td>
</tr>
<tr>
<td>EVEN</td>
<td>=EVEN (number)</td>
</tr>
<tr>
<td>ODD</td>
<td>=ODD (number)</td>
</tr>
<tr>
<td>EXP</td>
<td>=EXP (number)</td>
</tr>
<tr>
<td>FACT</td>
<td>=FACT (number)</td>
</tr>
<tr>
<td>LN</td>
<td>=LN (number)</td>
</tr>
<tr>
<td>LOG</td>
<td>=LOG (number)</td>
</tr>
<tr>
<td>LOG10</td>
<td>=LOG10 (number)</td>
</tr>
<tr>
<td>RAND</td>
<td>=RAND ( )</td>
</tr>
<tr>
<td>RandBetween</td>
<td>=RandBetween (lower, upper)</td>
</tr>
</tbody>
</table>
Date and Time Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date</td>
<td>=Date (year, month, day)</td>
</tr>
<tr>
<td>Today</td>
<td>=Today() (current date)</td>
</tr>
<tr>
<td>Now</td>
<td>=Now() (current Time)</td>
</tr>
</tbody>
</table>

Using Named Cells and Ranges in a Formula

- Use descriptive names.
- Begin with a letter character.
- Do not use hyphens or spaces.
- Names can be up to 255 characters; however, it is a good idea to keep them to less than 10 characters.

To Name Cells or Ranges

- Select the cell or the range you want to name.
- From the main menu, choose Insert > Name > Define.
- Enter a name in the Define Name dialog box, and click Add; then Click OK.
- Or click in the Name Box on the Formula bar, enter the name you want, and press the Enter key.

Creating Name Ranges Based on the Cell Values

- Select the cell or the range you want to name.
- From the main menu, choose Insert > Name > Create.
- Choose the location of the text labels in relationship to the cells/ranges.

To Delete Named Cells/Ranges

- Select the cell or the range you want to name.
- From the main menu, choose Insert > Name > Define.
- Select the cell/range name you want to delete, and click Delete.
- Click OK.

Data Entry and Management

- Excel is widely used for the entry and management of data.
- The key point on data management is to enter or organize the data, so they are in Excel's "list format."
Excel can keep track of information in Lists or Databases.

Lists

- Lists are organized by records.
- A Record is collection of information about a person, an object, or a thing.
- A Record is broken up into Fields, which store specific information common to all records.

Tips on Lists

- Use Lists to keep your data organized.
- Use "names" to refer to each column of data.
- Put the field names in the first row of the List.
- Keep column names short; some statistical packages have problems reading names longer than 8 characters.
- Do not mix data with analysis or plots in the same worksheet.
- If you need to enter character data:
  - Keep them aligned to the left.
  - Do not enter blanks as the initial characters of a cell.
  - Use numerical codes for any well defined classification variable, e.g. Gender:
    - 0 = Female,
    - 1 = Male.
- Use the VLOOKUP function in combination with numerical codes to display text values attached to the numbers.

Using Data Validation

- Select Data > Validation.
- Click the Settings tab, and specify a message to appear, if invalid data entered.
- Click OK.

About Text Values

- You can use the “&” (ampersand) operator to concatenate (or join) several text values. For example =A3&A4 will join text in cells A3 and A4.
- To include space between first and last, type =A2& " " &B2.
Using Page Setup, in printing
You can use the Page Setup dialog to customize the printing of your Spreadsheet.

Printing a Spreadsheet
- Choose File > Setup.
- Set page margins.
- Do Print Preview.
- Print.

Setting the print area
- File > Print Area.
- Set Print Area.

Printing Row or Column Titles on Every Page
- From the main menu, choose File > Page Setup.
- Click on the Sheet tab, and enter the row range you want to repeat in the Rows to Repeat at Top text box.
- Press the Enter key.
- Enter the column range you want to repeat in the Columns to Repeat at Left text box.
  Or, click on the minimize dialog icon to the right of the columns to repeat at left text box.
- Click OK.

Note: the rows and columns need to be defined in absolute terms. For example: if you want Rows 1 and 2 to repeat, you would enter $1:$2.

To Print Formulas on the Worksheet
- Select Tools > Options and the View tab.
- Check the Formulas check box under the Windows Selection.

Where to Get Help
If you need help with your project, you may contact Help Central Office at 742-HELP.
If you need help from your instructor, you may e-mail heide.mansouri@ttu.edu.
Exercises

1. Using the IF Function:
   Create a Formula that would subtract a 15% discount from an invoice, if the total was more than $200; otherwise, subtract 10% discount.
   a. In an Excel worksheet, create the following table:

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2</td>
<td>3</td>
</tr>
<tr>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>7</td>
<td>8</td>
<td>9</td>
</tr>
</tbody>
</table>

   b. Click in cell D4, then Click Insert > Function.
   c. Select the **IF** function from the list, and click OK.
   d. Type B4 >= 200 in the Logical-Test text box.
   e. Select the Value-if-true text box (use the tab key), and type B4*0.15.
   f. In Value-if-false text box type B4*0.10.
   g. Click OK.
   h. Copy the formula to cells D5:D7.

2. Using the PMT Function (monthly payment for a loan):
   Calculate the monthly payment for a $20,000 car loan at 8% interest rate that will pay off in 4 years.  
   \[ \text{= - PMT (0.08/12, 48, 20000)} \]

3. Create the following car loan payment table, and calculate the annual payments for different loan amounts and interest rates.

<p>| | | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
<td>7</td>
</tr>
<tr>
<td>8</td>
<td>9</td>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

   a. Type the formula  \[ \text{= - PMT ($B6, $C$3, C$5)} \] in cell C6.
   b. Copy and Paste to cells C6:F9. Note that $B6, indicates that we always want to refer to the values in column B, but the row reference (rate can change). Similarly, C$5 indicates that we always want to
Formulas SC

refer to the values in row 5, but column reference (loan amount) can change.

4. Payment to investment (annuity payment):
   How much should be deposited to an account each month to save $100,000 in 20 years with 6% annuity rate?

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Rate:</td>
<td>6%</td>
</tr>
<tr>
<td>3</td>
<td>Years of savings:</td>
<td>20</td>
</tr>
<tr>
<td>4</td>
<td>Amount you want to save:</td>
<td>$100,000</td>
</tr>
<tr>
<td>5</td>
<td>Annuity Payment:</td>
<td></td>
</tr>
</tbody>
</table>

   a. =PMT (B2/12, B3*12, 0, B4) with no formatted values.

5. Fixing Errors in Formulas:
   Suppose Tim’s commission is entered in the following table:

<table>
<thead>
<tr>
<th>Location</th>
<th>Sales</th>
<th>No. Flights</th>
<th>Average cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Austin, TX</td>
<td>$782</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>Atlanta, GA</td>
<td>$499</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>Duluth, MN</td>
<td>$776</td>
<td>4</td>
<td></td>
</tr>
</tbody>
</table>

   a. Create the table.
   b. Calculate the average costs.
   c. To Fix the Error in the table, click the cell with the Error.
   d. Click the Trace Error button drop-down list.
   e. Select Show Formula Auditing Toolbar from the list, and click on Error Checking button.
   f. Click the cell with zero (0) flights, type 1, and press Enter.
   g. Click Remove All Arrows button on the Formula Auditing Toolbar.
   h. Close the Formula Auditing Toolbar.

6. What is the future value of $2000 a year for 35 years into an IRA with 3% average rate of return?
   a. =FV(3%, 35, -2000)

Please e-mail your comments or suggestions to: heide.mansouri@ttu.edu