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Introduction 

Access 2016 ShortCourse - Part II is designed as an introductory course to Microsoft 

Access 2016 Queries, Forms and Reports.   

 

Queries are an essential part of databases. You can use a query to answer a simple 

question, to perform calculations, or to combine data from different tables. Queries 

that you use to retrieve data from a table or to make calculations are called Select 

Queries. Queries that add, change, or delete data are called Action Queries.  By 

using a query, you can assemble the data that you want to use before you design 

your report. 

 

Forms are often the most convenient layout for entering, changing, and viewing 

records in your database. You can use forms to control access to data, such as which 

fields or rows of data are displayed. You can also add buttons and other functionality 

to a form to automate frequently performed actions.   

 

Reports are used to present data in printed forms. You can create Reports for 

mailing labels, invoice tags, address and phone lists, sales and purchases analysis, 

and any other information that you store in a table.  

 

This ShortCourse assumes that you have already attended Microsoft Access 2016 

Part-I ShortCourse, or you are familiar with Microsoft Access 2016 Interface, and 

Access Database Design basics. 

 

mailto:heide.mansouri@ttu.edu
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Course Objectives 

After completing this ShortCourse, you should be able to: 

 Create a new database; 

 Use the Query Designer to create a select query that returns data from a single 

table;  

 Create a Select Query that asks you to enter parameters and then returns results 

that match those parameters;  

 Use a formula in a query to calculate a sum;  

 Use the Query Wizard to create a Select Query that returns data from two tables. 

 Add criteria to a query;  

 Sort the query results;  

 Create and modify forms;  

 Create basic reports;  

 Use Layout and Design views to change a report; and 

 Create mailing labels.  

 

Practice 1: Create a blank database  

 Start the Microsoft Access 2016 program. 

 From the File menu, click New.  By default, Blank Database is highlighted.   

 In the File Name box, type: Customers Files 

 Click the Create button.  

 File -> Save As -> Save Database As -> Backup Database -> Save As -> 

Save. 
 Click Enable Content. 

Practice 2: Create 3 tables, as follows 

 Using the Design View and the steps given on the next page; create 2 tables 

(Customers table and Orders table).   

 Create the 3rd table, the Products table, using the Microsoft Excel program.  

And then Import this Products table into your Access database (practice 3, on 

page 5).   

Notice that there is at least one common field (matching fields) in related tables.   

Remember that you can import only one worksheet at a time during an import 

operation. To import data from multiple worksheets, repeat the import operation 

for each worksheet. 
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 To create the Customers table, do the following:  

o Click the View drop-down menu (on the FIELDS tab of TABLE TOOLS), 

choose Design View. 

o Type Customers for Table Name: and then click OK. 

o Create the table Field Names for Customers table, choosing correct data 

types (see the look up table), and pressing the Enter key.  For example 

change the first Field Name to CustomerID, and change its Data type to 

Number. 

o When finished typing all the Field Names (table column headers), click the 

View drop-down button, click the Datasheet View button, and click Yes 

to save this table. 

o On Datasheet View, populate the Customers table, typing the phone 

numbers without formatting- we will format this using the Input Mask 

Wizard. 

o Close the Customers’ table (Right-click on this table’s tab and then click 

Close). 

 

 To create the Orders table, do the following: 

o On the Create tab (on the Ribbon), click the Table button. 

o From the View drop-down menu, choose Design View. 

o Type Orders for Table Name, and then click OK. 

o Choosing correct data types (see the look up table), create the table Field 

Names for Orders table, using the Enter key. 

o Click the View button, and click Yes to save this table. 

o Populate the Orders table. 

o Close the Orders’ table (Right-click on this table’s tab and then click Close). 
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 To create the Products table, do the following: 

o Minimize the Access program.  

o Start the Excel program.  

o Create the Products table.  

o Save your file and close the Excel program.  

o Switch to your Access database, to import this file into your database.  

 

                

 

 

 

 

 

Look up Table 
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Practice 3: Import the Products table 

 On the External Data tab, in the Import group, click the Excel icon, and then 

click Open. Note that the External Data tab is not available unless a database 

is open.  

 Browse to find your Products table - (file of type Excel), and then click OK.  

 Follow the steps, clicking Next, and selecting 

o For Field Option: ProductID, in Indexed: box; select Yes (No 

Duplicates).  

o Click Next. 

o Select the Radio button: Choose my own primary key, and then 

choosing the ProductID as this table's Primary Key. 

o Click Next. 

 In the Import to Table: box, type: Products table, and then click Finish.  

 Click Close.  Remember that you can import only one worksheet at a time 

during an import operation. To import data from multiple worksheets, repeat the 

import operation for each worksheet.  

 Open the Products table in the Design View (on the Home tab), click in the 

OrderID field box. 

 In the Field Properties, change the Field size of the OrderID to "Long 

Integer” to match this field’s property in Orders table.  

 Click Save and Yes. 

 Close the table. 
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Some Table Editing Tips 

 To edit a table in Datasheet View, use the HOME tab, and then use the Filter 

or Advanced buttons (on the Sort & Filter group). 

 Select entire records by clicking on the gray tile to the left of the record, and then 

use the menus, or right-click on the record, and select your option (copy, paste, 

cut, delete records). 

 To edit a table in Design View, and move to the next or previous field, press 

TAB or SHIFT + TAB keys (to go back). 

 To select the current Field Name or remove the selection from the current field, 

press F2. 

 To undo changes to current Field Name or Record, press Esc key.  Remember 

that Deleted records are NON-RETRIEVABLE. 

 To add a Total row to your table, on the Home tab, in the Records group click 

the Totals button (the predefined calculation button). 
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Input Mask 

 An input mask is a set of 

literal characters and mask 

characters that control what 

users can enter in a field.  

 It is a defined format for the 

field. 

 You can create Masks, using 

the Input Mask Wizard. 

 You can use Masks to control 

the format of data entered.  It 

does not change how the data 

is stored, which is controlled 

by the field’s data type and 

other field properties.  
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Practice 4: Create an Input Mask for phone number, using the Customers 

table.  

 In the Navigation Pane, right-click the Customers table and click Design View 

on the shortcut menu.  

 Click in the Phone Number field. 

 In the lower section of the design grid, on the General tab, click the Input Mask 

property box.  

 Click the Build button , to start the Input Mask Wizard, and then follow the 

instructions in the wizard.  

 Switch to Datasheet view (right-click the document tab for the open table and 

click Datasheet View on the shortcut menu). 

 Test your mask. 

 

Validation Rules  

 A Validation Rule is field specific rule that imposes a constraint that defines a 

set of values for a given field. 

 You use Validation Rules to restrict your data to the way it will be accepted in one 

or several fields. 

 You can type Validation Rules in, by hand or use the Expression Builder.  In 

our exercise, we will create and test several field validation rules. 

 Validation rules work hand in hand with Input Masks to prevent bad data entry. 

 You create Input Mask or Validation Rules on the Design View of a table, in 

the General tab of the Field Properties. 

Practice 5: Create a Validation Rule 

 Open the Customers table in the Design View. 

 Click on Phone number field.   

 Click in Validation Rule box.   

 Type:  Like “212*” or like “513*” or like “613*” or like "806*"  

 Press the Enter key. 

 In the validation text box, type:  The Area Code; must be 212, or 513, or 

613, or 806. 

 Click in the caption box and type:  Phone Number. 

 Save and return to Datasheet View. 

 Test the validation rule. 
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Practice 6: Create Relationships and Enforce the Referential Integrity  

 Close all open tables. 

 On the Database Tools tab, click the Relationships icon. 

 On the Show Table dialog box, click on each table, and then click Add. 

 When finished, close the Show Table dialog box. 

 Click-and-drag the matching field in one table and drop it on the matching field in 

another table (the Primary key, and the Foreign key). Remember: that data 

type for common fields in different tables should have the same data type, and 

the same size!  

 Check the Enforce Referential Integrity box.  

 Click on the Create button. 

 To Edit the Relationship between tables, just double-click on the link, and then 

Edit Relationship. 
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Practice 7: Creating a Form 

 Using the Form Wizard (Create tab -> Forms -> Form Wizard), create a new 

form based on the Customers table, using all the fields.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Follow the steps, choosing a Layout and a Style for your form. 

 Name your form: Customers Form, and then click Finish. 

 To add an image to a form, on the Layout View of the form, on the Form 

Layout Tools, on the Design tab (on the controls group), click on the Image 

button.  Find and add an image to your form. 

 Click on the Form View (View -> Form View) to see the effect of your design. 
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 In Form View, click on the New (blank) record icon , and then enter the 

following information (using the Tab key to move from one box to another): 

o CustomerID: 4 

o Last Name: Brink 

o First Name: Amy 

o Street: 22 Slide Rd.  

o City: Lubbock 

o State: TX 

o Phone Number: 8065551234 

o Chocolate Preference: 2 

 Close the form.  

 Open the Customers table to check that Amy Brink’s information was entered.  

 Close the Customers table. 

 Open the Customers table to check that Amy Brink’s information was entered.  

 Close the Customers table.  

Note: Deleting a form, does not delete the data, because data are stored in 

tables. 

Control Buttons  

Control buttons are available on Form Design Tools, or Report Design Tools, on 

Form Layout View, or Report Layout View. 

 

 

 

 

 

 

Practice 8: Adding Command Button to a Form  

 In Design View of a form, on Controls Section click the Form Control Button.    

 In the design grid, click where you want the command button to be inserted (in 

the Form Header for example).   

 Select Form Operations from the Categories: list, and select Print Current 

Form from the Actions: list. 

 Click Next. 



Microsoft Access 2016 Part-II ShortCourse Handout 

Heide Mansouri Technology Support Page 14 
Computing ShortCourse Manager                     IT Division                                                                        5/24/2016 
 Texas Tech University  

 

 

 

 

 

 

 

 

 

 

 

 

 

 Select the Printer icon, (Picture: radio button). 

 Click Next. 

 Name the button Printing Current Form. 

 Click Finish. 

 Try it in Form View.  Close the form. 

Note: Deleting a form, does not delete the data, because data are stored in tables. 

Queries 

You can use queries to filter your data, to perform calculations with your data, and to 

summarize your data.  A query is a multi-purpose object in Microsoft Access. It can 

be used to display data from a single table or multiple tables, perform calculations on 

your data, and modify data within your tables. The most common type of query is 

the Select Query.  Access provides two primary ways to create select queries — 

the Query Designer and the Query Wizard. 

 

Regardless of the tool you use, you follow some common steps when you create a 

select query: 

 Start by choosing a record source for the query. A record source can be one 

or more tables, one or more queries, or a combination of the two.  

 From the record source, select the fields that you want to see in the query. 

 Add any sorting, filtering, or other selection criteria to your queries 

 You can also use criteria that make a query ask you for input before it runs, 

and you'll see that later in this course. 
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After you finish adding fields and any selection criteria, run your query to see if it 

gives you the correct results.   

 

When you run a select query, Access displays the results in a datasheet. The result 

is called a record set (the result of running a query), and you can work with it in the 

same way that you work with a datasheet. For example, you can add or change data, 

and Access will write your changes to the tables that serve as the record sources for 

your query. You can also use your record sets to provide data for forms, reports, and 

even other queries.  Remember that unlike tables, record sets don't physically exist 

in your database. Instead, Access stores the query, and it only displays a record set 

when you run the query. 

 

The Query Designer gives you the most control over a Select Query. It also 

makes it easy to create a query that uses a single table as a record source. For 

example, this type of query makes it easy to list your assets and their purchase 

dates. 

 

Finally, you can use multiple tables, or other queries, as the record source for a new 

query. In fact, you'll query multiple record sources far more than you will single 

sources. Multi-source queries are how you answer questions such as which assets 

came from which suppliers, for example. 

 

The Query Wizard is the easiest way to get started building multi-source queries, 

especially if you're new to Access.  

 

Selecting the Columns 

To create the fields for a query, you use the table(s) or query (queries) displayed in 

the upper section of the window. Once you have decided on the originating object(s), 

you can select which fields are relevant for your query: 

 To select one field from the list, just click it  

 To select many fields on the same range, you can click one of them, press 

and hold Shift. Then click one field on the other end of the desired range  

 To select fields at random, click one of the desired fields, press and hold Ctrl; 

then click each one of the desired fields  

 To select all fields, you can click the * line on the list of fields  
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To Add Columns 

To make a field participate in a query, you have various options: 

 Once you have made your selection on the list in the top part of the query 

window, you can drag it and drop it in the bottom section of the query 

window  

 Instead of dragging a field or all fields, you can either double-click a field to 

add it to the query, or double-click the line with * to add all fields to the 

query  

 In the bottom part of the query window, click an empty Field box to show a 

combo box. Then click the arrow of that combo box and select an item from 

the list:  
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Practice 9: Creating Queries 

 On the Create tab, click the Query Design. 

 In the Show Table window, click Customers, and then click the Add. 

 Click Orders, and then click Add. 

 Click Products, and then click Add. 

 Choose the First Name, Last Name, Account#, and the UnitPrice from the 3 

tables, and drag them to query design grid.  

 Release the mouse button (or- double-click on the field names). 

 In the Ribbon, click the Run button         

 

 

Practice 10: Sorting the results of the query, using the query that you just 

created 

 In the Ribbon, click View, then Design View. 

 In the Last Name field, click in the Sort row.  

 When the drop-down arrow appears, click it, then click Ascending. 

 In the Ribbon, click the Run button.  

 The query should run, and sort the records alphabetically by Last Name. 

 In the Ribbon, click View, then Design View.  

 In the Customer Last Name field, click in the Sort row again, then click (not 

sorted). 

 Click the Run button.   

 Close the query. 
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Practice 11: Specifying Criteria 

 On the Create tab, click the Query Design.  

 In the Show Table window, click Customers table, and then click the Add. 

 Click Orders table, and then click Add. Close the dialog box. 

 Choose the First Name, Last Name, and Account#, from the 2 tables, and 

drag them to query design grid.  

 Click in the Account# field, click in the Criteria row.  

 Type:   >2500, and then press the ENTER key.  Access will surround the text 

values with double quotation (”), and date values with the # character.  

 In the Ribbon, click Run.  

 Query returns customers who have account number greater than 2500.  

Note: Criteria can look very different from each other, depending on the data 

type of the field to which they apply and your specific requirements. Some 

criteria are simple, and use basic operators and constants. Others are complex, 

and use functions, special operators, and include field references. 
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Practice 12: Use the Action Query to Calculate Totals 

 On the Create tab, click the Query Design.  

 In the Show Table window, click Products table, and then click the Add. 

 Click the Close button. 

 Choose the UnitPrice, and drag it to query design grid (or- double click the 

UnitPrice field).  

 Repeat this 2 more times. 

 In Design View Click the “Totals” button (the predefined calculation 

button).  A new row below the field name called Total appears.  

 Click on the Total row, and use the drop down list box to select the calculations. 

 Run the query. 
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Practice 13: Custom Calculation in Query (Crosstab Query) 

To calculate a 25% off sale price, we need to find UnitPrice*0.75 (no spaces)  

 On the Create tab, click the Query Design.  

 In the Show Table window, click Products table, and then click the Add. 

 Click Close.  

 Choose the UnitPrice, and drag it to query design grid.  

 Right-click on a new field, and choose Build…  

 Or, click the Build … button. 

 Enter UnitPrice*0.75, in the Expression Builder box. 

 Click OK.  

 Run the query. 
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Practice 14: Make a query to ask for input (parameter query)  

 On the Create tab, click the Query Design.  

 In the Show Table window, click Orders table, and then click the Add. 

 Double-click on the fields names. 

 Click the Criteria box for OrderDate, and type the text:    

               Between [Starting date] and [Ending date]  

 Run the query, and type 1/1/2008 for staring date, and 4/1/2008 for the 

ending date. 

 In the Ribbon, click the Run button. 

 Save and close the query.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Boolean operators 

 Boolean operators are expressions such as AND, OR, NEITHER, and NOR that 

allow you to add multiple criteria to a query. They take their name from George 

Boole, the mathematician who first used them. 
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Practice 15: Implementing the OR operator 

 On the Create tab, click the Query Design.  

 In the Show Table window, click Customers table, and then click the Add.  

Close the dialog box. 

 Choose the First Name, Last Name, and State and drag them to query design 

grid. 

 In the Criteria row, under the First Name field, type: Jim. 

 In the First Name field, click in the OR row under the criterion “Jim".  

 Type: Mary and then press the ENTER key.  

 In the Ribbon, click Run.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Practice 16: Implementing the AND operator 

 Return to Design View of the query (View > Design).  

 Remove the query criteria from the First Name field (Highlight them, and then 

press the DELETE key.)  
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 In the First Name field, click in the Criteria row.  

 Type: “Amy”, and then press the ENTER key.  

 In the State field, type: “NY” in the Criteria row, and then press the ENTER key.  

 In the Ribbon, click Run.  No records were returned, because there's no one in 

the table whose first name is Amy, AND lives in the state of New York. 

Note:  

 Access is not case sensitive 

 When query is open, right-click the query tab to view SQL codes. 

Using the Wild Cards in Query Criteria 

Wildcard symbols are codes used to allow you to make complex searches for 

information 

*   Any group of characters in this position  

 Example: B*ge finds Baggage, Barge, etc. 

?   Any single character in this position   

 Example: J?ne will find June and Jane 

#   Any single digit in this position                  

 Example: 199# will find all years between 1990 and 2000 

[ ]   Square brackets for inclusions   

 Example: Jo[ha]n finds John and Joan (includes any of the letters h & 

a) 

[!]  Square bracket and exclamation marks for exclusion.    

 Example :  Min[!t] finds Mine, & Mind but excludes mint 

 Or- Use the criteria in design view of the query. 

Practice 17: Implementing a Wild Card character 

 Return to Design View of the Query.  

 Remove all query criteria from all fields.  

 In the Last Name field, click in the Criteria row.  

 Type: H* , and then press the ENTER key. TIP: An asterisk (*) stands for any 

character or combination of characters.  

 In the Ribbon, click Run.  

 Right-click the Query’s tab, and then choose Save. 

 When the Save As window appears, type:  Last Names that begin with H in 

the Query Name box.  
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 Click the OK.  

 Close the query window.  

Practice 18: Creating Customers Listing Report 

 Close all open objects. 

 In the Navigation Pane, click the Customers Table to select it. 

 In the Ribbon, click the Create tab, and then click Report (in Reports group).  

 Click the Page Setup tab on the Report Layout Tools, and select Landscape. 

 Right-click the report’s LastName column, Select the Entire Column, and then 

adjust the column width. 

 Adjust the remaining report’s columns if necessary. 

 Use the Home tab, and the Text Formatting to adjust the orientation of the 

content of the report’s columns 

 Using the Design tab on the Report Layout Tools, select a Theme to apply to 

the report. 
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Practice 19: Editing the Report label and the Font size 

 Click the label with the caption Customers Table.  

 Click the label again. Now the label can be edited.  

 Edit the label to read Customers Report, and then press the ENTER key.  

 Click the CustomerID label, to select it.  

 On the Report Layout Tools, click the Format tab, and select a Font size of 

10 and bold. 

 Click the Page Setup, on the Reports Layout Tools tab, and on the Print 

Options tab, for margins type: 0.5 in the Top box, and 0.5 in the Bottom.  

Then click the OK button.  

 Click the View button, and select Print Preview. 

 By clicking on the report, the report view should zoom-out/zoom-in. 

 Click the Close Print Preview button. 

 Close the report.  

 When the alert window appears, click the Yes button, and save the report as 

Customers Report. 
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To Modifying Page Numbers on a Report 

 Open the report in Layout View. 

 On the Format tab, in the Controls group, click Page Numbers.  

 Choose the format, position, and alignment you want for the page numbers.  

 Clear the Show Number of First Page check box. 

 Click OK.  

 Switch to Print Preview to see how the numbers will look when you print the 

report. 

 

To Modifying Date or Time on a Report 

 Open the report in Layout View. 

 On the Format tab, in the Controls group, click Date and Time.  

 Click the date format you want.  

 Clear the “Include Time” check box if you do not want to include the time.  

 Click OK.  

   

Practice 20: Creating Mailing Labels 

 Click the Create tab.  

 On the Reports group, click Labels.  

 Select Avery in the Filter by manufacturer list.  

 In the list of labels, under Product number, select 5160.  

 Click the Next button, twice.  

 In the Available Fields list, double-click First Name.  

 Press the SPACE bar on the keyboard.  

 Double-click Last Name, then press the ENTER key.   

 Double-click Street Address, then press the ENTER key.  

 Double-click City, and then type a comma and a space.  

 Double-click State, and then type two spaces.  

 Click the Next button.  

 When the next screen appears, double-click the Last Name. 

 Then click the Next button.  

 When the next screen appears, type: Shipping Labels in the box. 

 Click the Finish button.  TIP: If you receive a warning box saying "Some data 

may not be displayed," you can click the OK button and ignore it.  

 Close the Shipping Labels report.  
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On Your Own Exercise 
 

Create a new report based on the Customers table using the Report Wizard.  

 In the Navigation Pane, click the Customers Table to select it. 

 In the Ribbon, click the Create tab, and then click Report Wizard (in Reports 

group).  

 Use all the fields to report, except the CustomerID field, using the  button. 

 Click Next.  

 Group the Customers by State (click on the State field and the click on the 

button).  

 Click Next. 

 Select a Sort Order, and then click Next. 

 Select Stepped style for report Lay out, Landscape for Orientation, and then 

click Next. 

 Title the report Orders Report.  Click Finish. 

 Close the Report Print Preview. 

 From the View button, select Layout view.  

 Change the font for the heading of the report to Arial Bold, using the FORMAT 

tab on the REPORT LAYOUT TOOLS tab.   

 Preview the changes, using the View button on the HOME tab. 

 Close the report. 

 Select Stepped style, and click Next. 

 Title the report Orders Report.  

 Click Finish. 

 Close the Report Print Preview. 

 From the View button, select Layout view.  

 Change the font for the heading of the report to Arial Bold, using the Format 

tab on the Report Layout Tools tab.   

 Preview the changes, using the Home tab. 

 Close the report.  
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Thank You! 

 

 

 

Please e-mail your questions, comments, or suggestions to heide.mansouri@ttu.edu. 

mailto:heide.mansouri@ttu.edu

