Objectives
After completing this course you should be able to:
• Setup and prepare TTU web space for use;
• Know general forms of Web page layouts;
• Use these tools and knowledge to develop a basic Web page;
• Create hyperlinks;
• Create ordered and unordered lists;
• Insert and link images; and
• Learn how to upload your page on the Internet.

Course Topics:
• Setting Up Your TTU Web Space
• Interface and Application Layout
• Site Definition
• Basic Text Options
• Inserting and Linking Images

I. Setting up your TTU web space
Having web space is a requirement of this course. If you do not have any web space, you can get free web space from Texas Tech. You must activate your web space in order to use it.

• Navigate to the eRaider Web site at www.eRaider.ttu.edu
• Click Manage your eRaider account
• On the “Personal WebPages box”, click Create
• Then activate your Web space. This usually takes about 10 minutes to activate

II. Interface & Application Layout
• Views
  o Code
  o Design
  o Code and Design
• Object Panel
- Holds common objects
- Can change type of objects

- Work area
  - Where site is designed

- Properties Panel
  - Holds properties for a selected object

These windows are Web document files that have been opened and panels with information and tools that you can use.

**Work Area**

The work area is a Document window with a toolbar at the top. It shows the current document approximately as it appears in a Web browser.
The different View modes are listed on the toolbar, followed by the title of the active document. This is also shown in the title bar of the window. You can update and change a Web page's title here. Other options include File Management, Preview, and Design Refresh.

View Modes

There are three different view modes in the work area.

You can switch between View modes by clicking one of the View buttons in the upper-left corner of the work area document or by using the View menu.

Code View

This is a basic HTML editor. If you would like to edit the HTML directly, use the Code view.
Any scripts such as JavaScript, VBScript, or PHP must be entered in the Code view.

Design View

Design view is the WYSIWYG editor. It shows approximately what your Web page will look like in a standard browser. You never have to look at the HTML code in this view.
Both Views

This option gives you the best of both worlds. It shows the Code view on the top half of the work area and the Design view on the bottom half. Changes made in the design half will be shown immediately on the Code view, but changes in the code will only show up in Design view after you click in the Design view half of the screen or select Refresh.

Panels

Dreamweaver separates different tools and functions into different Panels on the screen. The two panels you will probably use most are the Objects Panel and the Properties Panel.

Objects Panel

The Objects panel contains buttons for creating and inserting objects such as tables, layers, and images. It contains seven categories: Common, Layout, Forms, Text, HTML, Application, Flash Elements, and Favorites. The different categories can be accessed by clicking on the category name at the top of the Objects panel. The different tools available in the various Objects collections are listed in Appendix A.
Properties Panel

The Property panel (or Property inspector) lets you examine and edit properties for the currently selected page element. (A page element is an object or text.) You can select an element simply by clicking on it once. The contents of the Property panel vary depending on the element selected.

Text Options
- Adjust Properties using the properties panel
  - You can change size, color, and style and add bullets, align, and add hyperlinks all within the properties box

III. Site Definition

- Creating a Site
One of the first things to do when beginning a site with Dreamweaver is to create a local Site Definition on your machine. Setting up this local site in Dreamweaver means that you can use Dreamweaver with FTP to upload your site to a Web server, automatically track and maintain your links, and collaboratively share files.

To create a new site:
1. Follow the wizard to setup your site.

2. Choose **Site → New Site**
   
   In the Site Definition dialog box that appears, the **Local Info** category is selected.
   
   - **Site Name** – a name for your reference; it will not appear in the browser.
   - **Local Root Folder** – this is where your files are stored on your computer.
   - **HTTP Address** – this is the URL that your completed Web site will use. It can be left blank.

3. Select **Remote Info** from the Category list
   
   Choose from the Server options:
   
   - **None** – if you do not plan to upload your Web site to a server
   - **FTP** – to connect to your server through FTP
     
     - **FTP host name** – full Internet name of a computer system; for TTU’s Information Technology Personal Web Pages, you would enter: webpages.acs.ttu.edu
     - **Host Directory** – where your files will be stored on the server; often this is public_html/
     - **Login name and password** – The name and password you need to connect to the server; for your TTU personal Web page, this is your eRaider username and password.

4. Click **OK**

5. Go to Windows and Choose Files

6. The **Site Files** window will show up as a panel. You can choose to view your local files or the remote view if you have setup your remote server.

   Note that your Site Name appears at the top of the window.

   ![Site Files window](image)

   **Maintaining and Correcting**

   - In order to make changes to your site, you must make the change on your computer files first.
   - Once you make changes to the files on the computer, FTP them back to the server.
   - **VERY IMPORTANT**: Make sure the first file you send is named `index` or `default`; otherwise, you won’t be able to see your Web site.
IV. Working with Documents

Web documents are what make up a Web site.
To create a new document: Choose File → New

A. Page Properties

![Page Properties Panel]

Page titles, background images and colors, text and link colors, and margins are basic properties of every HTML document. The Category on the left of the Page Properties panel needs to be set to Appearance (CSS). From here it is possible to set Page Font, Size and Text color. After making changes click on Apply to see the effect on the page. Click OK to close the panel.

You can modify these in Page Properties.

To view Page Properties:
- Choose Modify → Page Properties, or

You can modify the basic properties here.
- **Title** – identifies and names the document.
- **Background image or color** – sets the overall appearance of the document.
- **Text and Link colors** – help site visitors distinguish regular text from hypertext and to see which links have been visited and which have not.

B. Text

A Web document is made up of many elements, including text. Text can be entered into your document simply by typing.

Note: The ENTER key works differently in Dreamweaver than it would in other text editors (such as MS Word). When you press ENTER in an HTML document, it creates
a new paragraph, leaving a blank space between. To leave out this blank space, press SHIFT-ENTER to insert a line-break instead of a new paragraph.

**Modifying Text**

### Using the Properties panel
It is possible to create properties for particular instances of text on a page by using the Properties panel. These properties include things such as heading sizes, font style, font size, font color, bold and italicized text and alignment.

The Properties panel displays two sets of options for formatting text. Click on the HTML or CSS buttons on the left of the panel to change the options.

It is set out like this because text can be formatted by either HTML tags and/or by styles (CSS). To distinguish between the two, think of CSS as aesthetic styling, making something look good, whereas HTML is used for functional emphasis.

### Formatting with HTML
With the HTML option it is possible to set heading sizes `<h1>` `<h2>` etc. make text bold `<strong>`, italicized `<em>`, create text lists `<ul>` `<ol>` and indent `<blockquote>` as well as adding links to text.

It is not possible to directly change the color, font or size from the HTML option, without having set them in the CSS option first.

Changes can be made to the text by either clicking at the appropriate point or highlighting text and selecting the desired formatting from the Properties panel.

Heading sizes, text indent and lists are paragraph formatted HTML tags and are created by clicking at the appropriate point in the text. Other options require that the text is highlighted first.

Formatting text with the HTML option formats text with appropriate HTML tags.

**Heading sizes**
These are important as keyword searches for search engines. Use heading size 1 for main headings, size 2 for secondary headings and so on.

Heading sizes apply to a paragraph of text therefore it is not possible to select a portion of text within a paragraph and give it a heading size. The heading will apply itself to the whole paragraph. Do not use the heading size as a substitute for bold text.
To apply a heading size just click within a line of text that is within a paragraph. In the Properties click where it says Format and from the drop-down choose a heading size.

Changing the appearance of headings Size, font and color of individual heading sizes (h1 <h2> etc.) can be changed by going to the Headings (CSS) category. Making <h1> smaller than <h2> by this method will not alter the importance of <h1> over <h2> (and so on) in regard to word search by search engines.

Text indent
This is applied to a paragraph. Click inside a paragraph of text and click on the text indent button.

Text lists
Each list item (bullet point or number) is created by using the return/enter key as if making a paragraph.

To create a list, it is best to enter the text required but not to separate each item with a paragraph or line break to begin with. Click at the beginning of the first list item and choose the type of list by clicking on one of the list buttons in the Properties. Then for each subsequent list item use the return key.

To modify the list e.g. to have Roman numerals instead of numbers, click inside the list on the page and click on the List Item button. This opens a dialogue with further options.

Non paragraph formatting
For Bold and Italicized options, highlight any piece of text and click on the appropriate button in the Properties panel.

Formatting with CSS
Further text formatting is available with the CSS option of the Properties e.g. font, colour and size. The styles created here are entered (by default) into a style sheet in the <head> part of the document code. The styles are then referred to in the <body> of the code by HTML, for instance:

```html
<p class="text1">Styled text</p>
```
OR

```html
<span class="text1">Styled text</span>
```

“text1” refers to the name given (user defined) for that particular style. In the examples above the first one has the style included as part of the paragraph tag. The second example has the style included in the <span> tag which corresponds to text that was highlighted on the page.
To format text with CSS you need to create a ‘Rule’ which is a named style with properties e.g. color, size and so on.

**C. Links**

There are three basic types of links in HTML: external site, internal site, and internal page.

To create a link:
1. Select the text to be the link.
2. Type in the link destination in the Properties panel, or
   - Click the folder to select the filename (internal),
   - Use the target to drag to a file in your site (internal).

**External Site Links**

External site links are links that go to a Web site away from your own site, such as Yahoo or Texas Tech. These sites are often not under your control.

To create an external site link:
1. Select the text to be the link.
2. Type in the complete Web address (including the http://) of the external site in the Properties panel link box.
   - ex: http://www.ttu.edu/

**Internal Site Links**

Internal site links connect to another page within your Web site.

To create an internal site link:
1. Select the text to be the link.
2. Type in the filename of the Web document to link to in the Properties panel link box, or
   - Click the folder to select the filename,
   - Use the target to drag to a file in your site.
   - ex: links.html

**Internal Page Links**

Internal page links connect to a specific place within a page in your Web site. This can be on the same page as the link or on a different page.

Internal page links are accomplished using named anchors at the position to which to connect. Named anchors are similar to bookmarks. They give a specific point on a Web page a name in order to allow links to "jump" to that portion of the page.

To insert a named anchor:
1. Position the cursor at the point where you want to place the named anchor.
2. Choose **Insert** → **Named Anchor**
3. In the **Anchor Name** box, type a name for the anchor.

   This can be anything you like.

To insert an internal page link:
1. Select the text to be the link.
2. Type in the filename of the Web document to link to, followed by a # and the anchor name.

   ➢ **ex:** links.html#fun

---

### D. Images

**Inserting Images**

To insert an image:

1. Place the insertion point where you want the image to appear.
2. Choose **Insert** → **Image**, or click the **Insert Image button** from the objects panel.
3. In the Insert Image dialog box that appears, click **Browse to choose** a file, or **type the path** for the image file.

4. Use the Properties panel to adjust the image properties.

**Linking Images**

- If you want to use the image as a link, insert the web address within the Link box in the Properties panel.
- In the Alternate Text box of the Image Properties panel, enter the text that will be displayed when the cursor is placed over the image.