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SAS Enterprise Guide 7.1 – Part I 

ShortCourse Handout 

 
Copyright 2005-2016 Heide Mansouri, Texas Tech University.  ALL RIGHTS 

RESERVED. Members of Texas Tech University or Texas Tech Health Sciences Center 

may print and use this material for their personal use only. No part of this material 

may be reproduced in any form without written permission from Heide Mansouri, the 

author. 
 

Introduction 

SAS Enterprise Guide (EG) is the most powerful module in SAS.  It is a Point-and-

click version of SAS.   

 

SAS Enterprise Guide is an easy-to-use Windows client application that provides: 

 Access to much of the functionality of SAS;  

 Ready-to-use tasks for analysis and reporting;  

 Easy ways to export data and results to other applications;  

 Scripting and automation; and  

 Code editing facility.  

SAS Enterprise Guide is designed to be used by novice SAS users as well as 

researchers and business decision makers who are already familiar with SAS 

programming for exporting data and results to other applications and creating 

reports, queries, and charts. 

 

When you use SAS Enterprise Guide, you are also using SAS software behind the 

scenes.  That is SAS Enterprise Guide is not a standalone program; SAS itself needs 

to be installed, for Enterprise Guide to work. 

 

SAS Enterprise Guide can connect to SAS on your local computer, or it can connect 

to SAS on another computer called a SAS server. As you access data and build tasks, 

SAS Enterprise Guide generates SAS code for you. When you run a task, the 

generated code is sent to SAS for processing and the results are returned to SAS 

Enterprise Guide. 

 

mailto:heide.mansouri@ttu.edu
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For this ShortCourse, it is assumed that you have completed the Base SAS 

ShortCourse or already know how to create SAS data sets.  It is also assumed that 

you are familiar with Elementary Statistics. 

 

 

 

 

 

 

 

 

 

 

 

SAS Press and SAS Documentation Example Code and data 

We will be using some of the SAS sample data sets included in Statistics Using SAS 

Enterprise Guide book, authored by James B. Davis 

http://www.sascommunity.org/wiki/Statistics_Using_SAS_Enterprise_Guide .  We 

will also be using SAS Enterprise Guide 7.1 and SAS 9.4 under Windows. 
 

Course Objectives 

After completing this ShortCourse, you should be able to: 

 Create and save projects; 

 Create a SAS data sets; 

 Create Scatter plots; 

 Calculate Summary statistics; 

 Import Excel files; 

 Create Frequency distribution for discrete data; 

 Perform One-Way ANOVA; 

 Create Summary tables; 

 Perform Two-Way ANOVA with balanced data using Linear models; 

 Make inference on a population proportion; 

 Calculate Pearson Correlation coefficient; and 

 Perform simple linear regression analysis. 

 

 

http://www.sascommunity.org/wiki/Statistics_Using_SAS_Enterprise_Guide
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Starting a New Project 

 From the Start menu choose All Programs 

 Select SAS -> Click on Enterprise Guide 7.1 

 In the Welcome to SAS Enterprise Guide window, click New Project.   

Note: You can have only one project open at a time in SAS Enterprise Guide.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

SAS Enterprise Guide Interface  

 The Project Tree - lists the data, tasks, code, and notes in your project.  

 The Workspace area- displays your data, code, logs, task results, and 

process flows.  

 The Servers List window – lists different tasks that can be opened by clicking 

on the Task Lists button. 

 Resources pane - enables you to access the  

o Task List,  

o SAS Folders,  
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o Server List, and  

o The Prompt Manager.  

o We use Tasks to define what we want. 

 Task Status - displays the status, queue position, and server of any task that 

is currently running.  

 Project Log - displays an aggregated log of the entire project. 

The Resources pane is displayed by default in the lower-left corner of the SAS 

Enterprise Guide window, and it provides access to the Task List, SAS Folders, the 

Server List, and the Prompt Manager. By default, the Resources pane displays the 

Server List. 
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The workspace 

 The workspace is the main area of the SAS Enterprise Guide application and is 

used to display your data, code, logs, task results, and process flows.  

 The workspace is always displayed and cannot be minimized.  

 There are four important features in the workspace:  

o Tabbed access to task and query items (when data set is open);  

o Context-sensitive toolbar;  

o Recently viewed items button; and  

o Workspace Layout option (when Right-clicking on Workspace). 
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Creating a new project 

You can start a new project either when you first start up SAS Enterprise Guide or 

when you close the open project and start another one. You can have only one 

project open at a time in SAS Enterprise Guide.  

 

To start a new project when you invoke SAS Enterprise Guide:  

 Click New Project in the Welcome to SAS Enterprise Guide window.  

 

To start a new project when SAS Enterprise Guide is already running: 

 Select File -> New-> Project.  

 You can also create a new project by clicking in the toolbar and then selecting 

Project from the drop-down list.  
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Setting Options 

 Select Tools -> Options.  

 On the Results tab, click the Results General, check the HTML.   

 On the Tasks tab, click the Tasks General, deselect and delete the Default 

footnote text for task output, and deselect Include SAS procedure title 

in results.   

 On the Managing Results, check mark the Automatically add output data 

to the project tree. 

 Click OK.  
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Enterprise Guide Help 

 From the Help menu, select SAS Enterprise Guide Help. 

 On Contents tab, double-click the folder icons to display the help topics. 

 Or- from the Help menu, select Getting Started Tutorial. 

 Click the Begin Tutorial link (Online). 

 Help -> Check for Updates. 

 Close this window. 
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Working with Projects 

 The Resources pane is displayed by default in the lower-left corner of the 

SAS Enterprise Guide window, and it provides access to the Task List, SAS 

Folders, the Server List, and the Prompt Manager.  

 By default, the Resources pane displays the Server List. You can view the 

other windows in the Resources pane by clicking the appropriate icon in the 

Resources pane toolbar or by using the View menu.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Working with Process Flows  

 A process flow consists of one or more objects and could contain a project 

tree.  

 An object is represented by an icon in the process flow, such as a data set, a 

task, and your results.  

 A process tree shows the relationship between two or more objects.  

 SAS Enterprise Guide creates a default process flow when you start a project.  

 For a single project, you can have multiple process flows. 

 To view the process flow, select View Process Flow, or click Process Flow 

in the project tree.  
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Differences between the process flow and the project tree 

 You can customize the process flow by turning grid lines on and off, by 

zooming, or by changing the background color. 

o Right-click on the Process Flow, and then select to change the 

background color. 

 You can create multiple Process Flows and copy and paste or move objects 

among them. 

 

Customizing the View of Process Flows 

 To turn off the grid line 

o Right-click in a process flow and select Grid. 

 To view all of the objects in your process flow at one time  

o Right-click in a process flow and select Zoom. 
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o Select the size (in percent) of the window. 

 To change the background color of the process flow  

o Right-click in a process flow and select Background Color. 

o Select the color that you want to use. By default, the background color 

is white. 

Task List 

We use the Task List to tell SAS Enterprise Guide what task we want to be 

performed.  The SAS Enterprise Guide tasks generate SAS code and formatted 

results for you.  The Task List window can be viewed in the Resources pane and 

contains a list of the analysis and reporting tasks that you can run on your data.  

 To begin a task, double-click the task name in the Task List window. If there 

is actively selected data that is opened in Update mode when you run a 

task, you are prompted to change it to 

Read-only mode before you can run the 

task.  

 To open the Task List, select View -> Task 

List. You can also choose tasks from the 

Tasks menu in the SAS Enterprise Guide 

window.  

 You can use the drop-down list to view the 

tasks in two different ways and to view task 

templates:  

o Tasks by Category - displays a list 

of tasks that are grouped by 

category.  

o Tasks by Name - displays an 

alphabetical list of tasks. The 

alphabetical list also includes the 

name of the SAS Procedure that is 

related to the task. To sort by the 

Procedure name, click the SAS 

Procedures column heading.  

o Task Templates - displays a list of 

your task templates.    
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Using Tasks in SAS Enterprise Guide 

 Use the selection pane on the left side of task window to select groups of options 

for the task (Data, Options, Titles, etc.).  

 The Variables to assign box lists the variables (or columns) in the data set. 

 The icon next to each variable represents the variable's type:  

 

 

 

 

 

 

 

 All tasks have a Data area where you assign variables to roles in the task. 

 The icon next to each task role indicates the type of variable that you can assign 

to the role. 

 You assign variables to roles by dragging them from the Variables to assign list 

and dropping them on the appropriate role in the Data list. You can also use the 

arrows to assign and remove variables from roles.  Variables can be assigned to 

more than one role. 
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Task Status Window 

 The Task Status window displays messages about the status of tasks as they 

process.  

 The Process Designer window also displays a different background color around 

the task item for each phase of processing. 

Data in SAS Enterprise Guide 

 SAS Enterprise Guide requires all Data that it accesses to be in table format.  

 Rows (also called observations) in a table are collections of Data values related 

to an object. 

 Columns (also called variables) in a table are collections of values that describe 

a characteristic. 

  

Column (Variable) Properties 

 Name - can be 1 to 32 characters long. They must begin with a letter (A-Z, 

either uppercase or lowercase) or an underscore ( _ ). They can continue 

with any combination of numbers, letters, or underscores, including blanks.  

However, when SAS Enterprise Guide processes a variable name, SAS Enterprise 

Guide internally converts it to uppercase. You cannot, therefore, use the same 

variable name with a different combination of uppercase and lowercase letters to 

represent different variables. For example, cat, Cat, and CAT all represent the 

same variable.  

 Type - is either character or numeric.  

 Character variables can contain any values. Missing character values are 

represented by a blank.   

 Numeric variables can contain only numeric values (the digits 0 through 9, 

+, -, . ,  and E for scientific notation).  

 Currency, date, and time data are stored as numeric variables. 

 Missing numeric values are represented by a period.  

 Length - A column’s length (the number of bytes that are used to store it) is 

related to its type.  

 Character variables have a default length of 12 bytes. 

 All numeric variables have a default length of 8 bytes.  

 Format - affects how data values are displayed. SAS data formats include 

character, numeric, and date and time.  
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 Informat - determines how data values are read into a SAS data set. You must 

use informats to read numeric values that contain letters or other special 

characters.  

 Label - A variable can have a label, which consists of descriptive text up to 256 

characters in length.  

 

To create a new program  

 Select File -> New Program. The new program opens in the workspace.  

 You can also right-click in the process flow and select New -> Program 

 The autocompleting, or code completion, feature in the program editor can 

predict the next word that you want to type before you actually type it 

completely.  

 To use the autocompletion feature, in the program editor, type the first one 

or more letters of the word that you want to use. A window opens with a list 

of suggested keywords that begin with those letters.  

 Navigate to the keyword that you want to use. 

o Continue to type until the correct keyword is selected. 

o Or- Scroll through the list  

o Double-click the selected keyword.  

o Or- Press the spacebar, ENTER, or TAB keys.  
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Example: 

 File -> New -> Program 

 Type the following program: 

 

 

 

 

 

 

 

 

 

 Click on the Run button. 

 View different outputs (PDF, HTML, simple SAS Output), if the settings are 

selected (Tools -> Options -> Results General). 

Exercise #1: Creating a New data Set 

 Select File > New > data.  The New data wizard opens to step you through 

the process of specifying the name and location of the new data and creating the 

initial columns.  

 Name your data Schools, and click Next. 

 Under Column Properties: select and change column Name A to ID. 

 For this column’s Label, type Student ID.  

 Change this column’s data Type to Numeric.  

 Add the following column headings (variable names) to the table, selecting 

columns from the Columns List and changing their names and properties as 

specified: 

o Age   Numeric 

o Gender  Character 

o Major   Character 

o GPA   Numeric 

o School   Character 

 To create a new column name, click New.  

 To rearrange the order of the existing columns, select the column in the 

Columns list that you want to move and click  or .  
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 To delete an existing column, select the column in the Columns list that you 

want to delete and click .  

 Close this new data window.  

 When completed, Click Finish. 

 Type the data from the following table into each cell in the grid by using the Tab 

or arrow keys to navigate around the grid.  (you can Copy & Paste data, one 

entry at a time)  

 Delete unused rows and columns.  View Table Properties. 

 Don't Close this new data window.  
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Scatter Plots 

• A scatter plot (also called Scatter Diagram, or Scatter Chart) is type of 

graph that is useful when you are plotting one multi-value (paired or 3-D) 

variable against a second multi-value variable. 

• Each data point in a scatter plot, represents a single observation (typically a 

human subject). 

• You should always create a Scatter plot for a given pair of variables prior to 

computing the correlation coefficient between those variables. 

• This is because The Pearson Correlation Coefficient is appropriate ONLY if the 

relationship between the variables is LINEAR. 

 

When to Use a Scatter diagram? 

 When you have paired numerical data; and  

 When trying to determine whether the two variables are related. 

 

Exercise #2:  Creating a Scatter Plot (to see the pattern of data) 

 While the table is open, from the Graph menu, select Scatter Plot . . .  

 Click yes, to protect your data (if you are asked). 

 Select 2D Scatter Plot. 

 Click the Data tab. 

 Select Age and drag it to Horizontal (axis) and select GPA and drag it to 

Vertical (axis) Data. 



SAS EG 7.1- Part I ShortCourse Handout 

Heide Mansouri  Revised: 9/14/2016 
Texas Tech University Page 20 
 

 On the Plots tab (under Appearance on the Plot tab), on the Data Point 

Marker, choose the Symbol: Star, and a Color. 

 On the Titles tab, uncheck and delete the default text.  

 On the Titles tab, clear the Footnote. 

 When finished assigning variables to roles and selecting options, click Run. Each 

pair of observations becomes a data point on the plot. 

 View the HTML output and the close this window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To change the protection mode, to edit data files 

 Open your data set 

 Select Edit > Protect Data to toggle the Update mode on and off. 

 You are prompted for confirmation when you change a file from Read-only 

mode to Update mode.  
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Assigning Data 

 To create reports and run analyses on the data, you select tasks from the Task 

List, either sorted by category or alphabetically.  

 A task is an analysis that you perform or a report that you create from your 

data.  

 Many Enterprise Guide tasks will require an analysis and /or classification 

variable. 

 The available roles vary depending on the task , but some of the most common 

are: 

o Analysis Variables are variables for which statistics will be produced, 

e.g. mean, standard deviation.  An analysis variable must be 

numeric. 

o Dependent variable is the response variable. 

o Classification variables are variables by which subjects 

(participants) will be classified within an. Classification variables can 

be either character (categorical) or numeric. 

o Group analysis by variables; are also discrete, numeric, or character 

variables.  For example Gender variable, with values male, and 

female. 
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Exercise #3: Creating a List data for Schools data set 

 Double–click to open the Schools data set (if it is not open). 

 From the Describe menu, select List Data . . . 

 Shift + Click on first and last variables names to select them all. 

 On the Data tab, drag all the variables to the right and drop them under the 

List variables heading, to assign procedures to variables. 

 On the Options tab, uncheck mark Print the Row number box. 

 On the Titles tab, for the Report Titles, uncheck mark the Use default text 

box, and delete the text for Footnote. 

 Rename the Title to “Schools Report” 

 Click the Preview Code button.  

 Close the Code Preview for Task window. 

 On the Titles tab, clear the Footnote. 

 When finished assigning variables to roles and selecting options, click Run. 

 View the HTML output and the close this window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Editing SAS program generated by a Task 

 To make changes to the programs generated by SAS Enterprise Guide, you 

can insert your own SAS code into the program associated with a task, or you 

can save the code generated by a task in a separate file which you can then 

edit and run. 
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 To preview the code generated by a Task, click the Preview code button in 

the lower-left corner of any Task Window.  

 And then click the Insert Code … button, to insert codes at specific points in 

the SAS program, by double-clicking to insert code. 

 

Enterprise Guide and SAS programs  

 To create a new SAS program, from the File menu, click New -> 

Program. The program editor opens and it is syntax-sensitive. 

 To open an existing SAS program, from the File menu, click Open -> 

Program. Navigate to the existing SAS program and click Open.  

 To save a program in a file: 

o Any new programs you write are automatically embedded in your 

project (the program’s code does not exist in a file outside of the 

project). To save a SAS program outside its project, click Save on the 

workspace toolbar for the Program window, or right-click the program 

icon in the Project Tree or Process Flow and select Save As from the 

menu.  

 To run your program, click Run on the workspace toolbar for the Program 

window.  

 

Changing the Report Style 

 From the Tools menu, select Options 

 On the Results tab, select HTML, if it is not selected. 

 On the HTML tab, change the Appearance Style, if you wish.  

 

Exercise #4: Calculating Summary Statistics (the Means Procedure in SAS) 

 Double-click to open the Schools data set. 

 From the Describe menu, select Summary Statistics . . .  

 Select GPA variable, and drag it to Analysis Variables. 

 On Statistics tab, for Basic statistics, select 3 from the Maximum 

decimal places drop down list. 

 On the Data tab, drag the Gender to Classification variable.  This gives 

you additional options such as Missing values: 

o The Missing Values drop-down menu lists Include and Exclude. 
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o Missing values can be set to include or exclude missing values from 

analysis.   The default for Missing values is “Exclude”. 

 On the Titles tab, clear the Footnote. 

 Click Run. 

 View the HTML output and the close this window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Frequency Distribution for Discrete Data  

 Discrete data can be summarized using the following distributions: 

o The frequency distribution, which lists the number of occurrences of 

each discrete value (character values, counts, and numeric 

classifications). 

o The percent distribution, which lists the percentage of occurrences 

of each distinct value in the sample. 
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o The cumulative frequency distribution, which lists a running total 

of frequencies. 

o The cumulative percent distribution lists a running total of the 

percentages.  

 

 Frequency distribution lists the number of occurrences of each distinct value 

(discrete data), in the sample.  The underlying SAS procedure is Proc FREQ. 

Exercise #5: Creating Frequency Distribution and Frequency Histogram for 

Discrete Data 

Using the ex03_07.sas7bdat file, create frequency distribution for discrete data, as 

follows: 

 File -> Open  -> Data … ->  Local Computer  -> My Computer\ShortCourses 

Material\SAS and SPSS\SAS\SAS Enterprise Guide -> Examples -> 

ex03_07.sas7bdat -> Open  

 From the Describe menu, choose One-Way Frequencies 

 On the Data tab, assign the Grade variable to the Analysis variables Data. 

 Assign Frequency to the Frequency Count role. 

 On the Statistics tab, check mark the “Frequencies and percentages with 

cumulative” radio button. 

 On the Plots tab, choose Vertical. 

 When finished assigning variables to roles and selecting options, click Run. 

 To make changes to the chart, Using the HTML output for this report, right-

click inside the graph, and then choose options from the pop-up menus. 

 View the HTML output and the close this window. 
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Exercise #6: Performing One-Way ANOVA Test 

48 women (35-45 years old) participated in a study that examines the effectiveness 

of certain interventions in increasing physical activity.  Their daily energy 

expenditure (DEE) is at most 35 kcal/kg/day (considered inactive).  Each woman was 

randomly assigned to one of 4 groups (Advice, Assistance, Counseling, and Control).  

After 6 months, the DEE for each woman is measured.   

 File -> Open  -> Data … ->  Local Computer  -> My Computer\ShortCourses 

Material\SAS and SPSS\SAS\SAS Enterprise Guide -> Examples -> 

ex06_01.sas7bdat -> Open  

 Analyze > ANOVA > One-Way ANOVA … 

 Assign the DEE variable to Dependent variables Task role. 

 Assign the Group variable to Independent variable Task role. 

 On the Means tab, click the Comparison, and then select the Fisher’s least 

significant -difference test (LSD).  Or, select Tukey’s Studentized 

range test (HSD) which has a higher Type II error rate. 

 On the Means tab, click the Breakdown, and then select Mean, Standard 

deviation, Variance, and Number of non-missing observations. 

 On the Plots tab, check both Box and Whisker, and Means 

 On the Titles tab, clear the Footnote. 

 When finished assigning variables to roles and selecting options, click Run. 

 View the HTML output and the close this window. 
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Results 

 Independent variable is Group (k=4) 

 Dependent variable is DEE 

 Coefficient of determination R2 = 0.519682 

  = 0.05 

 Degrees of freedom = n-k =48-4 = 44 
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 MS (Error) = 1.056959 

 T .025 = 2.01537 

 The Control group has the lowest sample mean.   All other groups are 

significantly higher.  

 

Exercise #7: Creating Summary Tables 

Sometimes Summary Tables are preferred over the Summary Statistics and One-

Way Frequencies.   Summary Tables need to be set up, and they do not produce 

graphs.  Using the SAS Attitude data set, create a Summary Table as follows: 

 File -> Open -> Data-> Local Computer -> My Computer-> ShortCourses -> 

ShortCourses Material\SAS and SPSS\SAS\SAS Enterprise Guide -> Sample -> 

Data Appendix -> attitude.sas7bdat -> Open 

 From the Describe menu, choose Summary Tables… 

 On the Data tab, assign Quality, Supervision, and Work variables to Analysis 

variables Data. 

 On the Summary Tables tab, right-click on the Preview Table, and then select 

Table Properties. 

 Click the Format tab, and then select Numeric from the Categories, and 

BESTw.d from the Formats box. 

 Click OK.   

 To add text to the table’s box area: 

o Right-click on the Preview table, and select Box Area Properties from the 

drop down menu. 

o On the General tab, select Use the following text, and type your text 

(Attitude, for example). 

o Click OK. 

 On the Summary Tables tab,  

o From Available Variables: one-by-one drag the 3 variables (Quantity, 

Supervision, and Work) into the cells, under the Box Area. Note: A 

summary table is constructed by dragging variables and statistics from the 

available boxes to the left and top portions of the Preview table. 

o From Available Statistics: drag Max, Mean, Min, N, and StdDev, to the 

right border of the last cell in the upper portion of the Preview table. 

 On the Titles tab, clear the Footnote. 
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 When finished assigning variables to roles and selecting options, click Run. 

 View the HTML output and the close this window. 
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Investigating a new Headache Drug 

The effectiveness of a new drug for the treatment of headaches is investigated in a 

clinical trial.  The new drug is administered at two dosages: 5 milligrams and 10 

milligrams (denoted by N05 and N10).  Female and male patients are randomly 

assigned to receive one of the two new dosages.  After one month, the patients 

completed a quality of life (QOL) questionnaire.  The QOL scores are on a 100-point 

scale.   The standardized mean score is 50.  The data is given in SAS Headache data 

set.  We want to test the claim that the mean responses are the same for all 

populations associated with the treatments.  Let  = 0.05.  We will use the Linear 

Model task to apply two-way factorial analysis of variance to this data.  

 

This example involves four population means: µij = µ + i +j + ()ij 
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 µ11 = µ + 1 +1 + ()11 is the mean response for all female patients who 

take the new drug at 5-milligram dosage.  

 µ12 = µ + 1 +2 + ()12 is the mean response for all male patients who 

take the new drug at 5-milligram dosage. 

 µ21 = µ + 2 +1 + ()21 is the mean response for all male patients who 

take the new drug at 5-milligram dosage. 

 µ22 = µ + 2 +2 + ()22 is the mean response for all male patients who 

take the new drug at 5-milligram dosage. 

Treatment main effects are i: the difference between the mean score of all patients 

who use the N05 or N10 dosage (µi.) and the mean score of all patients who use 

either new dosage (µ). 

 

Sex main effects are j: the difference between the mean score of female or male 

who use the N05 or N10 dosage (µ.j) and the mean score of all patients who use 

either new dosage (µ). 

 

Treatment * Sex interaction effects are ()ij 

 

H0: µ11 = µ12 = µ21 = µ22 

H1: At least two means are not equal 

 

Exercise #8: Two-Way Factorial ANOVA with Balanced data using Linear 

Models  

 File -> Open  -> Data … ->  Local Computer  -> My Computer\ShortCourses 

Material\SAS and SPSS\SAS\SAS Enterprise Guide -> Sample-> Data Appendix -

> headache.sas7bdat -> Open 

 From Data menu, Sort Data by treatment-> click Run. 

 Delete rows for other treatments (other than N05, and N10).  Note: To delete 

unwanted rows: Edit > Protect Data > Delete rows, and then Protect Data 

again (only the variables Treatment, sex, and QOL are selected for this 

analysis). 

 From the Analyze menu, select ANOVA  -> Linear Models … 

 Assign QOL to Dependent Variable Task role. 
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 Assign Treatment and Sex variables to Classification variables (Sex and 

Treatment main effects and a Sex * Treatment interaction effects). 

 On the Model tab, Ctrl + Click both Treatment and Sex variables, and then 

click Factorial (the resulting model has a main effect for each independent 

variables and all possible interactions).   

 On the Post Hoc Tests, click Least Squares (Least-Square means for 

comparisons on both main effects and interaction effects).   

 Click the Add button (you may need to adjust the dialog box to see the Add 

button). 

 On the Options for means tests: 

o At Class effects to use:, use the drop-down menu, to change False to 

True for each desired comparison (Treatment and Sex for example). 

o At Comparisons: 

 For Show p-values for differences, select All pairwise 

differences. 

 For Adjustment method for comparison, select a method 

computing p-values (Tukey for example). 

 On Plots tab, click the Custom List of Plots radio button, and then check the 

Interaction plot. 

 Check Dependent means for main effects, and Dependent means for two-

way effects. 

 On the Titles tab, clear the Footnote. 

 When finished assigning variables to roles and selecting options, click Run. 

 View the HTML output and the close this window. 
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Results 

 Independent variables are:  Treatment with a=2 and levels N05, N10, Sex 

with b=2 and levels F and M 

 Dependent variable is QOL 

 N..=32 
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 Coefficient of determination R2 = 0.314264 

 Degrees of freedom = n-k =24 -3 = 21 

 P-value = 0.0132 < 0.05, reject H0.  There is sufficient evidence to reject the 

claim that the mean responses are the same for all populations associated 

with the treatments.  At least two treatment-sample means are significantly 

different. 

Exercise #9: Making Inference on a Population Proportion, using One-Way 

Frequencies 

A poll of 423 likely voters examines Candidates Support a week before an election.  

There are three candidates in the election.  The responses are summarized in table 

EX04_07.  Test the claim that Smith has support among a majority of likely voters.  

Let  = 0.05 

 File -> Open  -> Data … ->  Local Computer  -> My Computer\ShortCourses 

Material\SAS and SPSS\SAS\SAS Enterprise Guide -> Examples -> 

EX04_07.sas7bdat -> Open  

 From the Describe menu, select One-Way Frequencies… 

 On the Data, assign Candidate to Analysis variables role, and Support to 

Frequency count role 

 On the Statistics tab, on the Binomial Proportions, check the Asymptotic test 

(used when  𝑛�̂�   and     𝑛�̂�(1 − �̂� ) ≥ 5 ).  That is, the condition is true when 

n is large and/or sample proportion �̂� =
𝑥

𝑛
   is not too close to 0.0 or to 1.0. 

 At Confidence Level, enter 95% 

 On the Results tab, From Order Output data by drop down list, select 

Descending Frequencies (so that Smith is first in the list). 

 On the Titles tab, clear the Footnote. 

 When finished assigning variables to roles and selecting options, click Run. 

 View the HTML output and the close this window. 
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Analysis: 

H0 : p ≤ 0.5 

H1 : p > 0.5 

P-value = 0.0659 (see the output) 
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Since the p-value ≥ 0.05, do not reject H0.  There is not sufficient evidence to 

support the claim that Smith has a majority of support among all likely voters.  That 

is, the sample proportion is not significantly greater than 0.5.  Note: p-value is a 

measure of the likelihood that the sample comes from the process where H0 is true.   

That is, the more the data agrees with H1 – the smaller the p-value. 

 

Exercise #10: Make inference on mean of a population of differences (paired 

t-test)  

A university assesses the quality of its education program by testing each student’s 

intellectual skills before their education course, and the after completion of the 

program.  The results from 22 randomly selected students are included in EX05_03 

data set. 

 Using EX05_03 data set, from the Analyze menu, select ANOVA -> t Test… 

 On the t Test type, select the Paired 

 On the Data, assign Pre and Post variables to the Paired variables role 

 On the Plots tab, check the Summary plot and Box plot types. 

 On the Titles tab, clear the Footnote. 

 When finished assigning variables to roles and selecting options, click Run. 

 View the HTML output and the close this window. 
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Exercise #11: Calculating Pearson Correlations Coefficient 

The Pearson correlation coefficient, represented by r, is a measure of strength of the 

linear relationship between two numeric variables.  We will use Ex07_01 SAS data 

set to determine the Pearson correlation coefficient for pairs of measurements in this 

data set. 

 File -> Open  -> Data … ->  Local Computer  -> My Computer\ShortCourses 

Material\SAS and SPSS\SAS\SAS Enterprise Guide 4 -> Examples -> 

EX07_01.sas7bdat -> Open 

 Analyze > Multivariate > Correlations 

 On the Data tab, Assign all the variables to Analysis Variables roles 

 On the Results tab, check Create scatter plot for each correlation pair 

 On the Titles tab, clear the Footnote. 

 When finished assigning variables to roles and selecting options, click Run. 

 View the HTML output and the close this window. 
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Results 

 The top number is the Pearson correlation coefficient r. 

 The second number is the p-value for the test of  

o H0:  = 0 

 n=10 for each pair of variables 

 For Midterm and final r=0.93656 and the p-value < 0.0001 

 For Final and Absent, r=-0.73530 

 For Final and Commute, r=0.46798 and the p-value =0.1726 

 

Exercise #12: Simple Linear Regression  

 File -> Open  -> Data … ->  Local Computer  -> My Computer\ShortCourses 

Material\SAS and SPSS\SAS\SAS Enterprise Guide 4 -> Examples -

>ex07_04.sas7bdat -> Open  

 Analyze > Regression > Linear… 

 Assign the Final variable to Dependent variables Task role. 

 Assign the Homework variable to Explanatory variables Task role. 

 On Statistics tab, check the Confidence limits for parameter estimates. 

 On the Plots tab, select Observed vs Independent and select the radio 

button for Confidence limits. 

 On Predictions tab, select Original sample, Prediction limits, and Show 

predictions check boxes. 

 On the Titles tab, clear the Footnote. 

 When finished assigning variables to roles and selecting options, click Run. 

 View the HTML output and the close this window. 
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Exercise #13: Finding the largest value in a BY-Group Using the SAS Class 

data set 

 File -> Open  -> data …  -> Servers  -> Local -> SASUSER (or SASHELP)> 

Class > Open  

 From the data menu, select Sort data … 

 Move the SEX, AGE, and HEIGHT variables over from Columns To Assign to Data 

and put them under the Sort by role  

 Select HEIGHT, and change the Height sort order from Ascending to Descending. 

This will ensure that the largest height is in the first observation for each age 

group 

 Run the Sort task.  

 Close the data set. 

 Select the sorted data set and bring up the Sort data task again (data > Sort 

data …).  

 This time, sort by SEX and AGE. Under Options, go to Duplicate Records and 

select keep only the first record for each 'Sort by' group.  

 On the Titles tab, clear the Footnote. 

 When finished assigning variables to roles and selecting options, click Run. 

 View the HTML output and the close this window. 
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Saving a project  

 File -> Save As from the menu bar.  Each project is saved as a single file 

and has a file extension of .egp  

 You can save data, programs, and results in separate files by right-clicking 

the icon for that item and selecting Export from the pop-up menu.  

 

To send data to Microsoft Word, or Excel 

 You can send a copy of a file in a SAS Enterprise Guide project to another user 

through electronic mail. Files that you can send include data, programs, logs, 

results, and notes.  

 You can also send a copy of the active file to Microsoft Word, Excel, or 

PowerPoint.   Note: In order to send results in the SAS Report format to any 

Microsoft Office application, you must have the SAS Add-In for Microsoft 

Office installed on your computer. 

 In the project tree, process flow or workspace, select the file that you want to 

send to another user.  

o Select File -> Send To E-mail Recipient.  

o Select File -> Send To -> Microsoft Word (or Excel). The active data 

source is inserted as a table into a new Microsoft Word document.  

 Or- on the Output Data tab, click Send To, and then 

 Word 

 Excel 
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Online Resources  

 Statistics Using SAS Enterprise Guide by James B. Davis, 2007.  Preview this 

book at http://books.google.com   

 Basic Statistics Using SAS Enterprise Guide, a Primer, by Geoff Der, and 

Brian S. Everitt, 2007. Preview this book at http://books.google.com  

 The Little SAS® Book:  a primer 5th edition, by: Susan Slaughter and Lora 

Delwiche, Feb. 11, 2013 available from TTU Safari e-Books http://library.ttu.edu  

  SAS Online Resources for Statistics Education 

http://support.sas.com/statlibrary 

 SAS Programming for Enterprise Guide Users, by Neil, 2007 available from 

TTU Safari e-Books.  

 

Where to Get Help 

 If you need help from me, please e-mail heide.mansouri@ttu.edu, or call       

834-2935 to make an appointment. 

 

Credit: Exercises used in this ShortCourse are Copyright 2007, SAS Institute Inc., 

Cary, NC, USA.  All Right Reserved.  Produced with permission of SAS Institute Inc., 

Cary, NC.  

 

Please e-mail your comments or suggestions to: heide.mansouri@ttu.edu  

http://books.google.com/
http://books.google.com/
http://library.ttu.edu/
http://support.sas.com/statlibrary
mailto:heide.mansouri@ttu.edu
mailto:Heide.mansouri@ttu.edu

