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Copyright 2005-2016 Heide Mansouri, Texas Tech University.  ALL RIGHTS 

RESERVED. Members of Texas Tech University or Texas Tech Health Sciences Center 

may print and use this material for their personal use only. No part of this material 

may be reproduced in any form without written permission from Heide Mansouri, the 

author. 
 

Introduction 

SAS Enterprise Guide provides a point-and-click interface to the power of SAS. 

The point and click environment helps you to import the data, analyze the data, and 

produce output.  

 

In this ShortCourse, you’ll learn how to use SAS Enterprise Guide to create Graphs, 

Reports and Queries. 

 

Depending on your exact needs, there are several tasks that can create a report 

such as List Report, List Data, Summary Tables, and Summary Statistics. 

 

The Enterprise Guide’s Query Builder enables you to extract data from one or more 

tables according to criteria that you specify. 

 

In this ShortCourse, it is assumed that you have completed at least the SAS- Part I 

ShortCourse and SAS Enterprise Guide- Part I or already know how to create SAS 

data sets.  This ShortCourse also assumes a familiarity with Elementary Statistics 

and Microsoft Access Queries. 

 

Course Objectives  

After completing this ShortCourse, you should be able to: 

 Create and save projects; 

 Create and Modify a List Report;  

 Use the Query Builder, to create Queries;  

 Join Tables by Using a Query ; 

 Create a Computed Column by using Expression Builder; 

mailto:heide.mansouri@ttu.edu
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 Create Summary Statistics; 

 Create Summary Tables; 

 Filter your SAS data set; 

 Create a Bar Chart ; 

 Create a Pie Chart; and  

 Combine the HTML results from multiple tasks in your project into a single 

document. 

 

Starting a new Project 

 From the Start menu choose Programs 

 Select SAS -> Click on Enterprise Guide 7.1  

 In the Welcome to SAS Enterprise Guide window, click New Project  

Setting Results formats 

 Tools -> Options  

 On the Results tab 

o HTML (Associated Viewer: Internet Explorer ) 

 On the HTML tab, select a Style: …. 

o PDF (Associated Viewer: Adobe Acrobat) 

 On the PDF tab, select a Style: ….  

o RTF (Associated Viewer: Microsoft Word) 

 On the RTF tab, select a Style: …. 

 File header …. 

 Author …. 

 Title …. 

o Text Output - generates results in text format.  

o Results -> Viewer -> Check the Associated Viewer: Internet 

Explorer (to be able to view the HTML output) 

 On the Tasks tab 

o Click the Tasks General, and then delete the “default footnote text 

for task output:” text. 

o Click the Output Library tab, and select a library for output data 

(EGTask is the default output library).  
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  You can add a new library to the search list by clicking Add 

and typing the name of the library.  

 You can remove a library by selecting the library that you want 

to remove and clicking Remove.  

 You can change the order of the search list by selecting the 

library that you want to move and clicking Up or Down. And 

then Apply. 

 Click OK. 

To Save a Project to a local computer  

 Select File -> Save Project As …, or click    on the toolbar.  

 To change the name or location of an existing project, select File -> Save 

project-name As.  

o In the Save window, click Local Computer, or select Local Computer 

from the Save in drop-down list.  

o Select a location for the project.  

o Enter the name of the project in the File Name box and click Save.  
 

Exercise #1:  Adding SAS Data sets to your project  

Before you can create reports or run analyses, you must add data to your 

project. 

 

 Select File -> Open -> Data… 

 Find and open Data folder in the SAS Enterprise Guide 7.1 Sample 

directory.  

 Press CTRL and select Orders, PRDSALE, Products data sets, and 

then click Open.  

 Close any open data set. 

 In the Process Flow window, right-click the Products data set, and 

select Properties from the pop-up menu. The Properties for Products window 

opens. You can see information about general properties such as the physical 

location of the data and the date it was last modified.  

 In the selection pane, click Columns, to view the columns properties (Name, 

Type, Length, Format, Informat, and Label) for the data item.  

 Click Cancel to close the properties window.  
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Exercise #2: Importing a Text File into your project, using Import Wizard  

 Select File -> Import Data…  

 Find and open Data folder in the SAS Enterprise Guide 7.1 Sample 

directory.  

 Click the FixWidth.txt file, and then click Open.  

 On Step 1 of 4, click the Browse button, and in the File name box, type 

Categories.  

 Click Save, and then click Next to specify the text format. 

 In the Text format area, select Fixed columns.  

 To indicate the end of the first column and the start of the second column, 

click the 5th tick mark on the ruler.  

 To indicate the end of the second column and the start of the third column, 

click the 20th tick mark on the ruler.  

 Click Next to specify attributes for each field.  

 To create a SAS data set that has two columns: CategoryID and 

CategoryName.  

o In the table of column attributes, column F1 is already selected. Click 

Modify to open the Field Attributes for F1 window. 

o In the Name box, type CategoryID (no space).  

o In the Label box, type Category ID. Make sure that variable Type is 

set to Number and click OK.  

o In the Name column, click F2, click Modify to open the Field 

Attributes for F2 window, and type CategoryName. 

o In the Label box, type Product Category.  Click OK. 

o In the Inc. column (Include/Exclude column), clear the check box for 

column F3 to exclude this column from the data set. 
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  Click Next  

 In the Import Data task window, click Finish.  

 Review the data set, and then close the Import Data dialog box. 
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Exercise #3: Importing an Excel data file into your project 

 Select File -> Import Data…   

 Find and open Data folder in the SAS Enterprise Guide 7.1 Sample 

directory.  

 Find and Open the SupplyInfo.xls file (Suppliers$).   

 Follow the steps , and then click Finish to import this data set. 

 Close the data table window. 
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Exercise #4: Creating Charts 

 In the Process Flow window, select the Products data set. 

 From the SAS Enterprise Guide menu, select Tasks -> Graph -> Bar 

Chart... 

 Click Vertical Colored Bar, and then in the selection pane, select Data.  

 In the Columns to assign list, select CategoryID and drag it to the 

Column to chart role.  

 In the Columns to assign list, select UnitsInStock and drag it to the Sum 

of role.  

 On the Appearance tab -> Bars -> select different colors for bars. 

 Click Run to create the graph. 

 On the Results-HTML tab, double-click the graph -> Graph Properties. 

 On the Bar tab, choose Cylinder from the Bar Shapes: drop down list, and 

check the Show labels box (under Data labels). 

 Click OK. 

 Close the chart windows. 
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How to assign variables to analysis roles 

After you select your data and your graph, in the selection pane, click Data to access 

these options.  

 Column to chart - The values of the column that you assign to this role 

define the categories of data to chart. You must assign one variable to this 

role.  

 Bar Sum of The column that you assign to this role determines the lengths of 

the bars. By default, if no column is assigned to this role, then the total 

number of observations (the frequency statistic) is used to determine the 

lengths of the bars. If a column is assigned to this role, then the sum of the 

values for each category determines the lengths of the bars.  

 To choose  “statistic used to calculate bar:” select Advanced in the 

selection pane (under the Appearance).  

 Line sum of – When creating Bar-Line Chart…, the columns that you assign 

to this role specify the variables to use for the line plots. To choose the 
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statistic that is used to plot each line, select Plots in the selection pane. By 

default, the sum of the values for each category is used to plot each line 

 Stack – When creating Bar Chart -> Stacked Horizontal Bar, the values of 

the column that you assign to this role determine the number of segments in 

each bar.  

 Group charts by - Separate charts are generated for each group. The groups 

are determined by the values of the column that you assign to this role.  

 To select the sort order for each variable -Select the variable under the 

Group charts by role, and then from the variable-name sort order drop-

down list, select Ascending or Descending.  

Exercise #5: Creating Bar-Line Charts 

 In the Process Flow window, select the Products data set again. 

 From the SAS Enterprise Guide menu, select Tasks -> Graph -> Bar-Line 

Chart... (Or double-click the Products table, and use the menu on the open 

table). 

 In the Columns to assign list, select CategoryID and drag it to the Column to 

chart role.  

 In the Columns to assign list, select UnitsInStock and drag it to the Line sum 

of role.  

 Click Run to create the graph. 

 Review and then close the chart windows. 
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Queries 

A query is a request to retrieve data from one or more data sources (tables).   

The Enterprise Guide Query Builder enables you to extract data from one or more 

tables according to criteria that you specify. In the background, the Query Builder 

generates Structured Query Language (SQL) code, which you can view.  

 

Using queries, you can 

 Join Tables; 

 Group and Summarize Data;  

 Classify data into groups based on the values in a column;  

 Perform summary functions on any of the columns in your query;  

 Examine relationships between data values;  

 Subset and sort your data;  

 Compute values; and 

 Group and summarize data.  

 

Building Queries 

SAS Query Builder enables you to extract data from one or more tables according 

to criteria that you specify.  In the background, the Query Builder generates 

Structured Query Language (SQL) code, which you can view if you are creating a 

simple query that involves filtering or sorting a single table, and then you can also 

use the Filter and Sort window to create your query. 

 

Creating a new query 

 To create a new query based on open data:  

o Open the data that you want to query and click the Query Builder 

button in the workspace   

 

 To create a new query without open data  

o Select Tasks -> Data -> Query Builder… 

o Then use the Change button  to select a table. 
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Exercise #6: Filter data set, using Filter and Sort …Task 

 On the Process Flow window, select the Products table. 

 Click Tasks -> Data -> Filter and Sort … 

 On the Variables tab, double-click on ProductName and UnitsInStock 

variables. 

 On the Filter tab, in the 1st box, select the UnitsInStock from the drop-

down list of variables.  

 In the 2nd box, select  “Greater than”  

 In the 3rd box, select or type “0” for the Value: (to create 

Products.UnitsInStock > 0 expression for Filter definition).   

 On the Sort tab, select the UnitsInStock  

 For Sort Direction,  choose  the Descending radio button. 

 Click OK.  

 View the results and then close the query result table. 
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Exercise #7: Creating a Query by Joining Tables, using the Query Builder 

task 

 In the Process Flow, click Products to make it the active data set. 

 Select Tasks -> Data -> Query Builder… 

 In the Query Builder window, click Add Tables… button.  

 In the Open Data window, double-click the Work.CATEGORIES file.  

 In the Query Builder window, click Join Tables… button.  

 Close the “Tables and Joins” window, but don’t close the Query Builder 

window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Exercise #8: Performing manual join 

 In the Process Flow window, select the Products table. 

 From the Tasks menu -> Data -> Query Builder… 

 Click Add Tables… button 

 In the Open Data window, select Orders table and click Open to add it to the 

query. Because no column name and type matches are found, a message 

window alerts you that “A suitable join could not be determined for the new 
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table. You will have to manually join the tables”. In the message window, 

click OK.  

 Although the column names are different, the values in the ProductID and 

PRODID columns are related and have same data types. You can join the 

Products and Orders tables on these columns.  

 Click the PRODID column and drag the cursor to the ProductID column, and 

then click OK. 

 Close the Tables and Joins window, but DON’T close the Query Builder 

window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Exercise #9: Creating a Calculated Column to Calculate the Profit 

We want to create a calculated column that contains the profit that is earned from 

each order. The Products data set contains the variable UnitPrice, which is the 

retail price of the product. The Orders data set contains the variables UPRICE, 

which is the cost, and QUANTITY, which is the number sold. From these three 

variables, you can calculate the profit that is earned from each order.  

                            Total Profit = (UnitPrice-UPRICE)*Quantity 
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 In the Query Builder window, on the Select Data tab, double-click the 

ProductName, and CategoryName, variables. 

 Click Computed Columns… button. 

 In the Computed Columns window, click the New… button  

 In the New Computed Column wizard, select the Advanced expression 

radio button, and then click Next. 

 On the Build an advanced expression page of the New Computed Column 

wizard, expand the Products table, located just below the row of operator 

buttons.  

 Double-click UnitPrice to add the variable to the Expression text box. 

 Click the subtraction operator (-).  

 Under the Tables, expand the Orders table.  

 Double-click the UPRICE variable. 
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 Use your mouse pointer to highlight the expression, and then click the 

parentheses operator (X).  

 Click the multiplication operator (*). 

 From the Orders table, double-click QUANTITY.  

 Click Next. 

 In the Column Name: and the Identifier: boxes, type Total Profit. 

 Click Next. 

 On step 3 of 4, at the bottom of the page, notice that for Format, none is 

used. Click the Change… button. 

 In the Categories: box, select Currency. In the Formats: box, select 

DOLLARw.d, from the drop down list.  Click OK. 

 Click Next to view a summary of the properties for the computed column, 

and then click Finish.  

 Close the Computed Columns window. 

 Review, and then click Run.  

 Close the Query Builder task. 
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Exercise #10: Sorting using the Query Builder Task  

 Open the last Query, and click the Modify Task button.  

 On the Sort Data tab, double-click the CategoryName, ProductName, and 

the UnitPrice variable names, in that order. 

 Click Run.  Click yes, to replace the result with previous result.  

 The table is first sorted by CategoryName, then by ProductName, and then 

by UnitPrice. 

 Close this output data window.  

 

 

 

 

 

 

 

Exercise #11: Performing a Linear Model Analysis 

You can use the Linear Models Task to determine whether the variable ProductName 

can be relied on, to predict Total Profit. 

 Select the Query-for-Products output to make it active. 

 Select Task -> ANOVA -> Linear Models 

 Assign Total Profit to Dependent variable role, and ProductName to 

Classification variable role.  This enables you to test for the effect of 

ProductName on Total Profit. 
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 In the selection pane, click Model. 

 In the Class and quantitative variables list, select ProductName. 

 Click Main. 

 Click Run. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 



SAS EG 7.1- Part II ShortCourse Handout 

Heide Mansouri                                                                                             Revised: 9/16/2016  
Texas Tech University Page 22 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



SAS EG 7.1- Part II ShortCourse Handout 

Heide Mansouri                                                                                             Revised: 9/16/2016  
Texas Tech University Page 23 
 

Results: 

 F=13.60 and P-value is less than 0.0001 (significant), so the results show 

that ProductName is a good indicator of profitability, as you might have 

suspected. 

 Looking at the column labeled Pr >| t | (in the last output table), you find 

that the following seven products with P-value < 0.05 are good indicators of 

profitability: 

o Cote de Blaye 

o Manjimup Dried Apples 

o Northwoods Cranberry Sauce 

o Raclette Courdavault 

o Sir Rodney's Marmalade 

o Thuringer Rostbratwurst 

o Vegie-spread 

 

Exercise #12: Creating Summary Statistics (Means Procedure)  

 In the Process Flow, click the PRDSALE table to make it the active data.  

 From the Tasks menu, select Describe, and then Summary Statistics… 

 Press CTRL and select ACTUAL, and PREDICT Variables, and drag them to 

the Analysis Variables Task roles. 

 Select the PRODUCT variable and drag it to Classification Variables Task 

roles. 

 Select YEAR and drag it to Group Analysis by Task roles.  

 Click Run. 

 Close the output window. 
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Exercise #13: Generating Summary Tables from a Query 

 
 In the Process Flow, select the last query we created to make it active (SAS 

data set with Total Profits). 

 From the Tasks menu, select Describe -> Summary Tables Wizard… (step 

1 of 6). 

 Click Next  

 From the Add button drop down list, select Total Profit variable, and select 

Average from the Statistic drop-down list (default is Sum).  

 From the Add button drop down list select Total Profit variable again, and 

select % of Column Sum from the Statistic drop-down list (Step 2 of 6). 

 Click Next  

 In the Rows section, click Add button and select CategoryName, and 

ProductName (Step 3 of 6).  

 Click Next  

 In the Rows: box; select Totals at Each level, from the drop down list (Step 

4 of 6). 

 Click Next twice (Step 5 of 6). 

 In the Table Title box, type: Profit By Products, and delete the Footnote 

(Step 6 of 6). 

 Click Finish.  

 Review the HTML output, and then close the Output window. 
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Exercise #14: Creating a Pie Chart 

 In the Process Flow, select the last query result data set that we created 

(SAS data set with Total Profits), to make it active.  

 From the Tasks menu, select Graph > Pie Chart…  

 In the Pie Chart gallery, select the Simple Pie icon.  

 In the selection pane, click Data. 

 Assign the CategoryName column to the Column to chart role.  

 Assign the Total Profit column to the Sum of role.  

 In the selection pane, click Layout. 

 Select 3-Dimentional. 

 Select Outside for Name:, Percentage:, and Statistic Value: from drop-

down list boxes  

 In the selection pane, click Titles. 

 For the graph, clear the Use default text check box and type Profit by 

Product Category. 

 Click Run.  

 Review the pie chart. Each slice of the pie is labeled with the category name, 

total profit, and percentage as you specified.  

 Close any open windows in the workspace.  
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Exporting and Sending Files (E-mail or to Word, Excel, or PowerPoint) 

 
You can send a copy of a file in a SAS Enterprise Guide project to another user 

through electronic mail. Files that you can send include data, programs, logs, 

results, and notes. 

 

To send files through e-mail, you need to have installed an e-mail application such as 

Microsoft Outlook that supports the Messaging Application Programming Interface 

(MAPI). Depending on the file type, you can also send a copy of the active file to 

Microsoft Word, Excel, Internet Explorer, or PowerPoint.  

 

Note: In order to send results in the SAS Report format to any Microsoft Office 

application, you must have the SAS Add-In for Microsoft Office installed on 

your computer. 
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To send a file to another user  

 In the project tree, or process flow, select the file that you want to send to 

another user.  

 Select File -> Send To -> E-mail Recipient…  

 

To send a file to Microsoft Word  

 In the project tree, or process flow, select the file that you want to send. You 

can send data, programs, logs, results, and notes to Microsoft Word.  

 Select File -> Send To -> Microsoft Word.  

To send a file to Microsoft Excel  

 In the project tree, or process, select the data file that you want to send.  

 Select File -> Send To -> Microsoft Excel.  

Exercise #15: Exporting the Query Results 

 Right-click on the query results data node (Filter_For_Products ) 

 Select Send to > Microsoft Excel. 

 Close the Excel program. 

To preview results  

 Open the results item that you want to preview by clicking the appropriate 

tab in the workspace or by double-clicking it in the process flow.  

 Select File -> Print Preview for results-name.  

 There are several options that you can select within the Print Preview window:  
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Exercise #16: Annotating a Process Flow 

If you have your results in SAS Report Format, then you can create an HTML 

Document and Add Results. 

 File -> New -> Report. 

 In the Select SAS items, select Pie Chart, and Summary Tables (using 

the Ctrl key). 

 Click the Add button. 

Note: You can e-mail your document by right-clicking the report, and then select 

Send To -> Email Recipient … 
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Online Resources  

 
 Statistics Using SAS Enterprise Guide by James B. Davis, 2007.   

 Basic Statistics Using SAS Enterprise Guide, a Primer, by Geoff Der, and 

Brian S. Everitt, 2007. Preview this book at http://books.google.com  

 The Little SAS® Book:  a primer 5th edition, by: Susan Slaughter and Lora 

Delwiche, Feb. 11, 2013 available from TTU Safari e-Books http://library.ttu.edu  

  SAS Online Resources for Statistics Education 

http://support.sas.com/statlibrary 

 SAS Programming for Enterprise Guide Users, by Neil, 2007 available from 

TTU Safari e-Books.  

 

Where to Get Help 

 If you need help from me, please e-mail heide.mansouri@ttu.edu, or  

call 834-2935 to make an appointment. 

 

Credit: Exercises used in this ShortCourse are Copyright 2007, SAS Institute Inc., 

Cary, NC, USA.  All Right Reserved.  Produced with permission of SAS Institute Inc., 

Cary, NC.  

 

Please e-mail your comments or suggestions to: heide.mansouri@ttu.edu  

http://books.google.com/
http://library.ttu.edu/
http://support.sas.com/statlibrary
mailto:heide.mansouri@ttu.edu
mailto:Heide.mansouri@ttu.edu

