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[bookmark: _bookmark1]Introduction
IBM SPSS Statistics 31 is a suite of statistical software available for Windows, Macintosh, and UNIX. It stores data as .sav files and saves output as .spv files. SPSS provides statistical analysis and data management through an accessible point-and-click interface, with an optional syntax editor for reproducible scripted analysis.

This course is designed for people who have just started to use SPSS Statistics and will only cover a few of the many basic statistical procedures available with SPSS Statistics 31. This course assumes the user is familiar with elementary statistics.

Course objectives:
· Create a dataset using the Data Editor
· Import data from Microsoft Excel
· Prepare data for analysis and create new variables
· Run analyses including frequencies, descriptives, correlations
· Create and edit charts
Preparation: Download the practice file grades.xlsx from your course materials and save it somewhere easy to find (e.g. the Desktop) before class begins. Or use the file provided during the in-person class

[bookmark: _bookmark2]Opening SPSS
Windows [image: ] > IBM SPSS Statistics App
[image: Screenshot of IBM SPSS Statistics welcome screen showing options for creating new datasets or database queries and restoring points. Includes a tutorial section with a sample bar chart illustrating distance correlation, and buttons for Help & Support, Tutorials, Community, and links to IBM Watson AI resources.

]

[bookmark: _bookmark3]Windows in SPSS Statistics

	Window
	Purpose

	Data Editor
	The main spreadsheet window. Contains all your data. Has two tabs: Data View (rows = cases, columns = variables) and Variable View (one row per variable, defines attributes).

	Viewer (Output Window)
	Displays results from every procedure you run — tables, charts, graphs, and text. Opens automatically when you run an analysis.

	Pivot Table Editor
	Open when you double-click a table in the Viewer. Lets you reformat, sort, and edit output tables before export.

	Chart Editor
	Opens when you double-click a chart in the Viewer. Provides detailed control over chart appearance.

	Text Output Editor
	Edit non-table output text (e.g. headers, log entries) before saving or printing.

	Syntax Editor
	Write and run SPSS commands as code. Open via File > New > Syntax. Every dialog has a Paste button that writes its syntax here automatically.



[bookmark: _bookmark4]Menus in SPSS Statistics
Each SPSS window has its own menu bar. The Data Editor's menus are the most commonly used:

	Menu
	What it does

	File
	Create, open, import, save, and export data and output files.

	Edit
	Cut, copy, paste data; modify preferences and options.

	View
	Toggle toolbars, gridlines, status bar, and value labels.

	Data
	Make global changes: sort, select cases, split file, merge files. Changes are temporary unless you save.

	Transform
	Compute new variables, recode, count values. Changes are temporary unless you save.

	Analyze
	All statistical procedures: descriptives, ANOVA, correlation, regression, factor analysis, etc.

	Graphs
	Create bar charts, histograms, scatter plots, box plots, pie charts, etc.

	Utilities
	Display variable information, control variable lists.

	Extensions
	Extension Hub, Install Local Extension Bundle, Install Python and R Modules, Custom Dialogue Builder for Extensions, Installed Extensions Report, Utilities

	Window
	Switch between open SPSS windows or minimize all.

	Help
	Access tutorials, case studies, and the Statistics Coach.


Tip: The Help menu contains a Statistics Coach that helps you identify the right procedure for your analysis, and a Tutorial with introductory exercises.



Exercise 1 — Getting Started & Navigating the Interface
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Goal: Open SPSS, load the sample demo.sav file, and locate every area of the interface.

1. Open SPSS Statistics. If a startup dialog appears, click Close (or choose 'Type in data' if prompted).
2. Open the demo data file: File > Open > Data. Navigate to: C:\Program Files\IBM\SPSS Statistics\Samples\English\demo.sav and click Open.
3. In the Data Editor (Data View), hover your cursor over a column heading — a yellow tooltip appears showing the variable label.
4. Go to View > Value Labels (or click the Value Labels button on the toolbar). Numeric codes change to descriptive labels (e.g. 1 becomes 'Male'). Toggle it off and on.
5. Click the Variable View tab at the bottom. Each row is a variable. Read through the Name, Label, Values, and Measure columns.
6. Click back to Data View. Identify: Menu Bar, Toolbar, Data View / Variable View tabs, Status Bar.
7. In the Menu Bar, click through Analyze, Graphs, and Transform — do not select anything, just read the options.
8. Go to Help > Topics and then Help > Tutorial. Browse the opening page, then close.
9. Open the Syntax Editor: File > New > Syntax. Type: * My first syntax comment. Close it without saving.
10. Go to File > Export and look at the output format options (HTML, PDF, Word, Excel). Click Cancel.
Challenge: In the Data Editor, right-click on any variable name column header and choose Variable Information. Read what SPSS tells you about that variable. Then go to Utilities > Variables for a full list.



Section 2 — Defining Variables, Entering & Importing Data
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[bookmark: _bookmark7]Rules for variable names
· Each variable name must be unique.
· Names can be up to 64 characters long. The first character must be a letter or @, #, or $.
· Names cannot contain spaces. Use underscores instead (e.g. test_score_1).
· The period, underscore, and @, #, $ can be used within a name — but avoid ending with a period or underscore.
· Reserved words cannot be used: ALL, AND, BY, EQ, GE, GT, LE, LT, NE, NOT, OR, TO, WITH.
· Names are case-insensitive for analysis, but case is preserved for display.

[bookmark: _bookmark8]Variable measurement levels
SPSS uses three measurement levels. Setting this correctly determines which statistics and chart types are available.

	Level
	Definition
	Examples

	Nominal
	Categories with no meaningful order
	Gender, zip code, department, religious affiliation

	Ordinal
	Categories with a meaningful rank but unequal intervals
	Satisfaction rating, education level, income bracket

	Scale (Continuous)
	Numeric data with a meaningful metric —
equal intervals
	Age, weight, income, test score, time


For ordinal string variables (e.g. Low / Medium / High), use numeric codes (1, 2, 3) and define value labels. Numeric codes are more reliable for analysis.


[bookmark: _bookmark9]Data View Window
[image: Screenshot of IBM SPSS Statistics Data Editor showing a blank spreadsheet with columns labeled var1 to var7 and rows numbered 1 to 20. Interface includes menu options like File, Edit, Data, and Analyze, with status bar indicating SPSS Statistics Processor is ready.

]
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[bookmark: _bookmark11]Setting up Variable View — column by column

	Column
	What to set

	Name
	Short variable name (no spaces). Use lowercase and underscores.

	Type
	Data type. Numeric for most analysis data. String only for text you will not analyse numerically.

	Label
	Full readable description — appears in all output tables and charts.

	Values
	Numeric codes for categorical variables. Click the cell, then the … button to open the Value Labels
dialog and assign labels.

	Missing
	User-defined codes for missing data (e.g. 99 or -1). SPSS excludes these from calculations.

	Decimals
	Number of decimal places to display. Set to 0 for ID, gender, and count variables.

	Measure
	Nominal, Ordinal, or Scale — sets the measurement level used by analysis procedures.



Best practice: complete Variable View entirely before entering a single value in Data View. Fixing variable definitions after data entry is much harder than doing it upfront.



[bookmark: _bookmark12]Essential data management operations

	Operation
	What it does

	Sort cases
	Data > Sort Cases — order rows by one or more variables ascending or descending.

	Select cases
	Data > Select Cases — analyse only a subset (e.g. only students who passed, only one gender).

	Split file
	Data > Split File — run the same analysis separately for each group. Remember to reset after.

	Compute variable
	Transform > Compute Variable — create a new variable using a formula.

	Recode
	Transform > Recode Into Different Variables — change value ranges to new codes.

	Recode into same
	Transform > Recode Into Same Variables — replace existing values (e.g. recode 0 as system-missing).

	Merge files
	Data > Merge Files — add cases (rows) or variables (columns) from a second dataset.




Exercise 2 — Create a Dataset from Survey Responses
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Goal: Build a dataset from scratch using 10 hypothetical survey responses. Set up Variable View fully before entering data.

The survey collected: Participant number, Gender, Age, Year in school, Current GPA, High School GPA, Confidence (1–10 scale), and Computer experience (years).
1. Go to File > New > Data to open a blank Data Editor.
2. Click the Variable View tab. In the Name column, type these variable names (press Enter after each): Case, Gender, Age, Year, GPA, HSGPA, Confidence, CompExp.
3. For the Year variable: click the Values cell, then the … button. Add four value labels: 1 = Freshman, 2 = Sophomore,
3 = Junior, 4 = Senior. Click OK.
4. For Gender: add value labels 1 = Male, 2 = Female. Click OK.
5. For Confidence: in the Label column, type: On a scale of 1-10, how confident are you that you will learn statistics?
6. For CompExp: in the Label column, type: How many years of computer experience have you had?
7. Set Measure to Nominal for Case and Gender. Set all others to Scale.
8. Set Decimals to 0 for all variables except GPA and HSGPA.
9. Switch to Data View. Make sure View > Value Labels is checked. Enter the 10 cases from the table below:
10. Case 1: Male, 23, Freshman, 3.20, 3.11, 6, 5 | Case 2: Male, 25, Sophomore, 3.00, 2.90, 8, 2 | Case 3: Female, 31,
Senior, 2.70, 2.50, 3, 15 | Case 4: Male, 27, Junior, 3.90, 3.60, 10, 4 | Case 5: Female, 27, Sophomore, 3.11, 3.20, 8,
8 | Case 6: Male, 22, Freshman, 3.00, 3.40, 7, 2 | Case 7: Male, 22, Sophomore, 3.50, 3.80, 10, 9 | Case 8: Female,
28, Junior, 2.22, 2.70, 3, 5 | Case 9: Male, 22, Senior, 2.90, 3.10, 5, 1 | Case 10: Male, 27, Senior, 3.30, 3.10, 8, 7
11. Save: File > Save As. Name the file with your last name and click Save.
Challenge: To add a variable between existing ones: click the GPA variable row in Variable View to highlight it, then select Edit > Insert Variable. A blank row appears above. Name it and define its properties.

[bookmark: _bookmark14]Importing data from Excel
When importing Excel files, SPSS uses the first row as variable names by default. Variable names that contain spaces will have spaces removed automatically during import.

· Go to File > Import Data > Excel.
· Select your .xlsx file and click Open.
· In the Read Excel File dialog: Ensure Yes radio button is selected for the question “Are variable names included at the top of your file” or select the row number using the up or down arrows for the row with variable names. Leave the other fields with their default values or selections.
· Click OK. The data appears in the Data Editor. Save as a .sav file immediately.
Files created in Microsoft Word should be saved in Plain Text format (.txt) before importing into SPSS.



Exercise 3 — Import an Excel File
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Goal: Import the grades.xlsx practice file containing test scores for 10 students.

The file contains: Student ID, Gender, Test1 score, Test2 score, Test3 score.
1. Go to File > Import Data > Excel.
2. Navigate to the grades.xlsx file you downloaded before or was provided to you before the session and click Open.
3. In the Read Excel File dialog: Ensure Yes radio button is selected for the question “Are variable names included at the top of your file” or select the row number using the up or down arrows for the row with variable names. Leave the other fields with their default values or selections. The preview should show rows of student scores.
4. Click OK. The data loads into the Data Editor.
5. Save immediately as a .sav file: File > Save As > name it Grades.sav. Do not close this file.
6. In Variable View, check the Measure column — score_midterm, score_final, and avg_score are set to Scale. Change any that are not.
7. Switch to Data View and verify all 30 rows of data are present.
Exercise 4 — Generate a New Variable (TestAverage)

[bookmark: _bookmark16]Goal: Use Transform > Compute Variable to create a mean test score variable.

1. With Grades.sav open, go to Transform > Compute Variable.
2. In the Target Variable box, type: TestAverage
3. In the Numeric Expression box, type: mean (Test1, Test2, Test3) and click OK.
4. A new column named TestAverage appears in Data View with the mean score for each student.
5. In Variable View, set the Label for TestAverage to: Average of score_midterm, score_final, and avg_score and set Measure to Scale.
6. Save the file (Ctrl/Cmd+S).
Challenge: Create a second computed variable: TotalScore = score_midterm, score_final, and avg_score. Then use Transform > Recode Into Different Variables to create a 'Grade' variable: TotalScore below 240 = 1 (Fail), 240-269 = 2 (Pass), 270-284 = 3 (Merit), 285+ = 4 (Distinction).



Section 3 — Descriptive Statistics
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[bookmark: _bookmark18]Four key procedures

	Procedure
	When to use it and path

	Frequencies
	Best for categorical and scale variables one at a time. Produces frequency tables, counts, %, mean, median, mode, percentiles, charts. Path: Analyze > Descriptive Statistics > Frequencies.

	Descriptives
	Best for a compact summary of multiple scale variables. Produces mean, SD, min, max, range, skewness, kurtosis, z-scores. Path: Analyze > Descriptive Statistics > Descriptives.

	Explore
	Best for detailed inspection: normality tests, outlier identification, boxplots, stem-and-leaf. Path: Analyze > Descriptive Statistics > Explore.

	Crosstabs
	Best for two categorical variables: frequency counts and % for every combination. Path: Analyze
> Descriptive Statistics > Crosstabs.




[bookmark: _bookmark19]Descriptives options

	Statistic
	What it measures
	Note

	Mean / Sum
	Arithmetic average and total
	Default — always shown

	Std. Deviation
	Avg. distance of values from the mean
	High SD = high variability

	Variance
	Standard deviation squared
	Useful for inferential tests

	Range
	Max minus Min
	Quick spread indicator

	Minimum / Maximum
	Smallest and largest values
	Good for catching data entry errors

	S.E. Mean
	How much the mean may vary across samples
	Relates to confidence intervals

	Skewness
	Asymmetry of the distribution
	0 = symmetric; normal = ~0

	Kurtosis
	Peakedness of the distribution
	0 = normal; positive = peaked




[bookmark: _bookmark20]Statistics available by measurement level (one-click and Frequencies)

	Data type
	Statistics available
	Reason

	String
	No statistics calculated
	—

	Numeric, Nominal or unknown
	Range, Min, Max, Mode
	No mean — unordered categories

	Numeric, Ordinal
	Range, Min, Max, Mode, Mean, Median
	Ordered but unequal intervals

	Numeric, Scale (continuous)
	Range, Min, Max, Mode, Mean, Median, Std. Deviation
	Full suite of statistics


One-click descriptives: select one or more variables in the Data Editor, right-click, and choose Descriptive Statistics. SPSS automatically runs the appropriate statistics based on measurement level — the fastest way to get a quick summary.



Exercise 5 — Run Descriptive Statistics on Grades Data
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Goal: Produce descriptive statistics for the four continuous variables in the Grades dataset.

1. Open Grades.sav (or continue from Exercise 4).
2. Go to Analyze > Descriptive Statistics > Descriptives.
3. Move score_midterm, score_final, and avg_score, and TestAverage into the Variable(s) box using the arrow.
4. Click Options and additionally select: Variance. Set display order to Alphabetical. Click Continue.
5. Click OK. The Descriptive Statistics table appears in the Output Viewer.
6. Read the table: what are the mean scores for each test? Which test had the highest variance?
7. Now go to Analyze > Compare Means > Means.
8. Move score_midterm, score_final, and avg_score, and TestAverage to the Dependent List. Move Gender to the Layer 1 box.
9. Click Options — Mean, Number of Cases, and Std. Deviation are selected. Click Continue, then OK.
10. In the Report table, compare mean scores between male and female students. Which group performed better on score_midterm?
Challenge: Try the one-click method: in Data View, click the score_midterm column header to select the whole column, then right-click > Descriptive Statistics. Compare the output to what you got from the full Descriptives procedure.
Exercise 6 — Frequency Tables and Output


[bookmark: _bookmark22]Exercise 6 — Frequency Tables and Out put


Goal: Use Frequencies on the demo.sav file, edit a results table, and save the output.

1. Open demo.sav (:\Program Files\IBM\SPSS Statistics\Samples\English\demo.sav).
2. Go to Analyze > Descriptive Statistics > Frequencies.
3. Click Statistics and select: Mean, Median, Std. Deviation, Variance. Click Continue.
4. Move Income category in thousands (inccat) into the Variable(s) box. Click OK.
5. The frequency table appears in the Output Viewer. Read the Valid Percent column — what percentage of respondents are in each income bracket?
6. Right-click the output table and choose Edit. The Pivot Table Editor opens.
7. In the editor, explore: Table Looks (pre-designed formats), Edit Content (change any cell text), and Format menu (column widths). Close the editor.
8. To save the output: from the Viewer window choose File > Save As. Name it and click Save.
9. To export: File > Export. Choose Word Document (docx) or PDF. Click OK.
Viewer output display options only affect new output produced after you change them. Existing output in the Viewer is not reformatted retroactively.



Section 4 — Charts & Graphs
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[bookmark: _bookmark24]Two ways to create charts

	Method
	How to access

	Chart Builder (recommended)
	Graphs > Chart Builder — drag-and-drop with live preview. More flexible and better for learning. Click OK to dismiss the intro dialog.

	Legacy Dialogs
	Graphs > Legacy Dialogs — older menus. Faster for standard charts when you know exactly what you want.


[image: Screenshot of a software dialog box titled "Chart Builder" providing instructions on setting measurement levels and defining value labels for variables before creating a chart. The dialog includes an information icon, a checkbox option to prevent the dialog from showing again, and two buttons labeled "OK" and "Define Variable Properties...".

][image: Screenshot of a bar chart selection menu showing three chart types: Simple, Clustered, and Stacked, each represented by a small colored icon. The menu includes options for data summaries with radio buttons for groups of cases, separate variables, and individual cases, along with Define, Cancel, and Help buttons at the bottom.

][image: Screenshot of a line chart selection menu displaying three chart types: Simple, Multiple, and Drop-line, each represented by distinct icons with blue and green lines. Below, radio buttons allow choosing data summaries for groups of cases, separate variables, or individual cases, with "Summaries for groups of cases" selected, alongside Define, Cancel, and Help buttons.

]
[bookmark: _bookmark25]Common chart types and when to use them

	Chart type
	Best for
	Example use case
	

	Bar chart (simple)
	Compare counts or means across categories
	Frequency of each income bracket; mean score by gender
	
[image: Screenshot of a dropdown menu displaying various chart and graph options for data visualization, including bar, line, pie, boxplot, and scatter plots. Icons next to each option use distinct colors and symbols to represent chart types, aiding quick identification for users selecting visualization tools.

]

	Bar chart (clustered)
	Compare counts/means across categories split by a second variable
	Wireless service ownership by PDA ownership
	

	Histogram
	Show distribution of a single scale variable
	Distribution of test scores; sales amounts
	

	Boxplot
	Show median, IQR, and outliers; compare groups
	Heat resistance by alloy type; score by gender
	

	Scatter plot (simple)
	Relationship between two scale variables
	Sales vs. fuel efficiency; midterm vs. final score
	

	Line chart
	Change over time or across ordered categories
	Average scores across multiple assessments
	

	Pie chart
	Proportions of a categorical variable
	Department breakdown (use sparingly)
	

	Error bar chart
	Group means with confidence intervals
	Results from t-tests or ANOVA
	



[bookmark: _bookmark26]Editing charts — the Chart Editor
Double-click any chart in the Viewer to open the Chart Editor.
· Change colors: double-click a bar or data point > Properties dialog > Fill & Border tab.
· Add data labels: Elements menu > Show Data Labels.
· Edit axis labels: double-click the axis label text, then retype.
· Change axis range: double-click axis scale > Scale tab > set min/max.
· Add titles: from the Options menu or Chart > Titles and Footnotes.
· Export: right-click the chart in the Viewer > Export > choose PNG, PDF, or PowerPoint.


Exercise 7 — Create a Clustered Bar Chart

[bookmark: _bookmark27]Exercise 7 — Create a Clustered Bar Chart
Goal: Using demo.sav, create a chart that shows the relationship between wireless telephone service and PDA ownership.

1. With demo.sav open, go to Graphs > Chart Builder. Click OK to dismiss the intro.
2. On the Gallery tab, choose Bar. Drag the Clustered Bar icon onto the canvas area.
3. From the variable list on the left, right-click Wireless service (wireless) and select Nominal as its measurement level.
4. Drag Wireless service to the X-Axis drop zone.
5. Right-click Owns PDA (ownpda) in the variable list and select Nominal.
6. Drag Owns PDA to the Cluster drop zone in the upper-right corner of the canvas. Bars will now be colored by PDA ownership.
7. Click OK. A clustered bar chart appears in the Output Viewer.
8. Double-click the chart to open the Chart Editor. Double-click one bar cluster to open Properties and change colors.
9. Go to Options menu > Title and add a descriptive chart title. Close the Chart Editor.
Exercise 8 — Descriptive Analysis with Charts (contacts.sav)

[bookmark: _bookmark28]Goal: Use the contacts.sav file (a sales team's contact database) to analyze department distributions and sales data. Open the contacts.sav file: C:\Program Files\IBM\SPSS Statistics\Samples\English\contacts.sav
Part A — Pie chart of departments:
1. Go to Analyze > Descriptive Statistics > Frequencies.
2. Select Department as the analysis variable. Click Charts, select Pie charts, click Continue. Click OK.
3. Right-click the pie chart in the Viewer, select Edit. In the Chart Editor, go to Elements > Show Data Labels. Close the Chart Editor.

Part B — Bar chart of departments (descending count):
1. Go to Analyze > Descriptive Statistics > Frequencies (or click the Recently Used Dialog button and select Frequencies).
2. Click Charts, select Bar charts, click Continue.
3. Click Format, select Descending counts, click Continue. Click OK.
4. Compare the pie chart and bar chart — which communicates the department distribution more clearly?

Part C — Histogram of last sale amounts with normality check:
1. Go to Analyze > Descriptive Statistics > Frequencies. Click Reset. Select Amount of Last Sale.
2. Deselect 'Display frequency tables' (not useful for continuous scale data with many values).
3. Click Statistics. Check: Quartiles, Std. deviation, Min, Max, Mean, Median, Skewness, Kurtosis. Click Continue.
4. Click Charts, select Histograms and tick 'Show normal curve on histogram'. Click Continue. Click OK.
5. Examine the histogram. Is the distribution symmetric or skewed? Read the Skewness value in the Statistics table.
Challenge: Run Analyze > Descriptive Statistics > Frequencies on Company Rank. Click Format, select Descending values, click Continue. Click OK. This produces a frequency table and bar chart ordered by descending value — useful for identifying the most common ranks.



Exercise 9 — Variable Transformation (Log Transform)

[bookmark: _bookmark29]Exe
Goal: Transform a right-skewed variable using a log transformation and assess the effect on the distribution.

Still using contacts.sav:
1. Go to Transform > Compute Variable.
2. In Target Variable, type: logsale
3. In Numeric Expression, type: LN(sale) — this applies a natural log transformation. Click OK.
4. Go to Analyze > Descriptive Statistics > Frequencies. Select logsale as the analysis variable (deselect Amount of Last Sale).
5. Click Statistics. Select Mean, Median, Skewness, Kurtosis. Click Continue. Click Charts > Histograms > Show normal curve. Click Continue. Click OK.
6. Compare the skewness and kurtosis values before and after transformation. Are the mean and median now closer together?
7. The histogram should be much more aligned with the overlaid normal curve after transformation.
The log transformation is appropriate when a variable takes only positive values and is right-skewed. It cannot be applied to zero or negative values.



[bookmark: _bookmark30]Goal: Analyse customer spending across service categories and handle zeros as missing values. Open telco_missing.sav: C:\Program Files\IBM\SPSS Statistics\Samples\English\telco_missing.savExercise 10 — Customer Spending Analysis

1. Go to Analyze > Descriptive Statistics > Descriptives.
2. Select: Long distance last month, Toll free last month, Equipment last month, Calling card last month, Wireless last month as analysis variables. Click OK.
3. Read the means — note that they are very low because customers who don't have a service have a recorded value of 0, distorting the average.
4. To recode 0s as system-missing: Transform > Recode Into Same Variables. Select all five spending variables.
5. Click Old and New Values. In Old Value, type 0. In New Value, select System-missing. Click Add, then Continue. Click OK.
6. Go to Analyze > Descriptive Statistics > Descriptives again (recall the dialog). Click Options, deselect Min and Max, select Skewness and Kurtosis. Click Continue. Click OK.
7. The means are now conditional on the customer actually having each service — dramatically different from before. Which service has the highest average spend?


Section 5 — Statistical Tests
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[bookmark: _bookmark32]Choosing the right test

	Research question
	Variable types
	Test
	SPSS path

	Compare 2 independent groups
	1 Scale + 1 Nominal (2 groups)
	Independent t-test
	Analyze > Compare Means > Independent-Samples T Test

	Compare same group twice
	1 Scale measured twice
	Paired t-test
	Analyze > Compare Means > Paired-Samples T Test

	Compare means across 3+ groups
	1 Scale + 1 Nominal (3+ groups)
	One-way ANOVA
	Analyze > Compare Means > One-Way ANOVA

	Compare group proportions
	2 Nominal / Ordinal variables
	Chi-square
	Analyze > Descriptive Statistics
> Crosstabs > Statistics

	Relationship between 2 scale variables
	2 Scale variables
	Pearson correlation
	Analyze > Correlate > Bivariate

	Relationship between 2 ordinal variables
	2 Ordinal variables
	Spearman correlation
	Analyze > Correlate > Bivariate (change method)

	Predict one variable from others
	1+ predictors + 1 Scale outcome
	Linear regression
	Analyze > Regression > Linear




[bookmark: _bookmark33]Reading test output — what to look for

	Output element
	What it tells you

	Sig. (p-value)
	Probability of the observed result by chance. Sig. < .05 = conventionally statistically significant.

	t (t-statistic)
	Test statistic for t-tests. Larger absolute value = greater difference relative to variability.

	F (F-statistic)
	Test statistic for ANOVA. Compares between-group to within-group variance.

	df
	Degrees of freedom. Reflects sample size and number of groups. Larger = more power.

	Mean Difference
	In t-tests: arithmetic difference between group means. More informative than p alone.

	r / r-squared
	Effect size for correlations and regression. r-squared = % variance in outcome explained.

	Chi-square (χ²)
	Discrepancy between observed cell counts and what you'd expect if rows and columns were unrelated.

	Post-hoc tests
	After a significant ANOVA: identify which specific groups differ (Tukey, Bonferroni).


Important: p < .05 tells you the result is unlikely due to chance — it does not tell you the practical importance of the finding. Always report effect sizes (Cohen's d, eta-squared, r) alongside p-values.
Exercise 11 — Explore Distributions and Normality


[bookmark: _bookmark34]Goal: Use the Explore procedure to compare distributions and test normality assumptions. Dataset: ceramics.sav — heat resistance data for standard and premium alloys.

Open ceramics.sav: C:\Program Files\IBM\SPSS Statistics\Samples\English\ceramics.sav
1. Go to Analyze > Descriptive Statistics > Explore.
2. Select Degrees Centigrade as the Dependent variable. Select Alloy as the Factor List variable.
3. In the Label Cases by box, select labrunid.

4. Click Statistics, select Outliers, click Continue.
5. Click Plots, tick 'Normality plots with tests', click Continue. Click OK.
6. In the output, find the Tests of Normality table. Look at the Shapiro-Wilk Sig. column for each alloy type.
7. For the Standard alloy: is Sig. > .05? (Not significant = fits the normal curve well.)
8. For the Premium alloy: is Sig. < .05? (Significant = fits the normal curve poorly — not normally distributed.)
9. Find the Normal Q-Q Plots. For the standard alloy, data points should follow the straight diagonal line closely. For the premium alloy, they deviate markedly — especially at higher temperatures.
10. Find the Boxplot. The premium alloy's box is tighter (less spread) but has outliers above — explains the skew.

Results interpretation:
· A significant Shapiro-Wilk test (Sig. < .05) means the distribution deviates significantly from normal.
· Stem-and-leaf plots: for premium bearings, values cluster in 1530–1543 degrees, then disperse at higher temperatures.
· Q-Q plot: the straight diagonal line represents expected values if data were normal. Deviations from this line indicate non-normality.
Exercise 12 — Chi-Square Test with Crosstabs

[bookmark: _bookmark35]Exercise 12 — C hi-Square Test


Goal: Use Crosstabs and Chi-square to test whether service satisfaction differs across store locations. Dataset: satisf.sav. Open satisf.sav: C:\Program Files\IBM\SPSS Statistics\Samples\English\satisf.sav
Context: a retail company surveyed 582 customers at 4 store locations regarding service satisfaction.
1. Go to Analyze > Descriptive Statistics > Crosstabs.
2. Select Store as the Row variable and Service satisfaction as the Column variable.
3. Click Statistics, select Chi-square and Contingency coefficient. Click Continue. Click OK.
4. In the output, read the Store x Service Satisfaction Crosstabulation table. Which store appears to have fewer satisfied customers?
5. Find the Chi-Square Tests table. Read the Pearson Chi-Square Sig. (2-sided) value. Is it greater or less than .05?
6. If Sig. > .05 (e.g. .178), we cannot reject the null hypothesis — differences are likely due to chance. Stores appear to offer similar service levels overall.
7. Now recall Crosstabs (use the Recently Used Dialog button). Add Contact with employees as a Layer variable. Click OK.
8. The cross-tabulation now splits by whether customers had contact with a store representative.
9. Find Chi-square Sig. for customers who DID have contact. Is it < .05? This means the association between Store and satisfaction IS significant for that group.
10. Read the Symmetric Measures table — the Contingency Coefficient quantifies the strength of the association.

Chi-square assumption check:
· Independence of observations: each case must be from a different person — one row per respondent.
· Expected cell counts: no more than 20% of cells should have expected count < 5. SPSS reports this in a footnote under the Chi-Square Tests table.
While chi-square tells you whether a relationship exists, it does not tell you the strength of the relationship. Use Contingency Coefficient, Cramers V, or Phi for strength.



Exercise 13 — Pearson Correlation & Scatter Plots

[bookmark: _bookmark36]Exe
Goal: Study the association between motor vehicle sales and fuel efficiency using correlations and scatter plots. Dataset: car_sales.sav.
Open car_sales.sav: C:\Program Files\IBM\SPSS Statistics\Samples\English\car_sales.sav Pearson correlation background:
· The correlation coefficient r measures the linear relationship between two scale variables.
· r ranges from -1 to +1. Perfect linearity = r = ±1. No relationship = r close to 0.
· Interpretation: |r| < 0.3 weak; 0.3–0.5 moderate; > 0.5 strong.

Part A — Initial correlation:
1. Go to Analyze > Correlate > Bivariate.
2. Select Sales in thousands and Fuel efficiency as analysis variables. Ensure Pearson is ticked. Click OK.
3. Read the Pearson Correlation value. Is it positive or negative? Is the Sig. (2-tailed) less than .05?
4. Interpretation: a non-significant negative correlation suggests designers should not focus solely on fuel efficiency to drive sales.

Part B — Scatter plot to check for outliers:
1. Go to Graphs > Chart Builder > OK. Select Scatter/Dot gallery and double-click Simple Scatter.
2. Drag Sales in thousands to the Y-Axis and Fuel efficiency to the X-Axis.
3. Click the Groups/Point ID tab, select Point ID Label, drag Model variable to the Variable box.
4. Click OK. Identify any potential outliers labeled in the scatter plot (e.g. Metro, F-Series).

Part C — Remove an outlier and re-run:
1. Go to Data > Select Cases. Choose 'If condition is satisfied', click If.
2. Type: model ~= 'Metro' (the ~= operator means 'not equal to'). Click Continue, then OK.
3. Recall the Bivariate Correlations dialog. Deselect Sales in thousands; select Log-transformed sales (lnsales). Click OK.
4. After removing the outlier and using log-transformed sales, how has the correlation changed?

Part D — Control for vehicle type (Split File):
1. Go to Data > Split File. Select Compare groups. Move Vehicle type to the Groups Based On box. Click OK.
2. Recall Bivariate Correlations and click OK to rerun.
3. Now correlations are computed separately for automobiles and trucks. For automobiles, is there a significant positive correlation between sales and fuel efficiency?
4. For trucks, is the correlation significant? What does this tell you about the different buyer motivations?
5. IMPORTANT: After finishing, go to Data > Split File > Analyze all cases, do not create groups. Click OK to reset.
Challenge: Create a scatter plot of Log-transformed sales vs Fuel efficiency, using Vehicle type to set marker colors. In Chart Builder > Simple Scatter, drag Vehicle type to the Color drop zone. Do the two vehicle groups form distinct clusters? What does this suggest about analysing them separately?



[bookmark: _bookmark37]Quick Reference — Menus, Assumptions, Key Terms & Golden Rules



[bookmark: _bookmark38][bookmark: _bookmark39]SPSS menu map for common tasks

	Task
	Menu path
	Procedures / notes

	Descriptive Statistics
	Analyze > Descriptive Statistics
	Frequencies, Descriptives, Explore, Crosstabs

	Compare Means / t-tests
	Analyze > Compare Means
	Independent-Samples T Test, Paired-Samples T Test, One-Way ANOVA, Means

	Correlation
	Analyze > Correlate
	Bivariate (Pearson, Spearman), Partial

	Regression
	Analyze > Regression
	Linear, Binary Logistic

	Charts
	Graphs > Chart Builder
	All chart types via drag-and-drop gallery

	Legacy Charts
	Graphs > Legacy Dialogs
	Quick standard charts via menus

	Compute variable
	Transform > Compute Variable
	Any formula-based new variable

	Recode
	Transform > Recode Into Different / Same Variables
	Change value ranges to new codes

	Sort cases
	Data > Sort Cases
	Order rows ascending / descending

	Select cases
	Data > Select Cases
	Analyse a subset of cases

	Split file
	Data > Split File
	Run analyses separately by group

	Merge files
	Data > Merge Files
	Add cases or variables from a second file

	Syntax
	File > New > Syntax
	Write and run SPSS commands as code




[bookmark: _bookmark40]Key test assumptions

	Assumption
	Applies to
	How to check in SPSS

	Normality
	t-test, ANOVA, Pearson r
	Test with Shapiro-Wilk (Explore). Sig. > .05 = approximately normal.

	Homogeneity of variance
	Independent t-test, ANOVA
	Levene's test (in output). Sig. > .05 = equal variances.

	Independence of observations
	All parametric tests
	Ensured by study design — one independent data point per person.

	Scale / interval data
	t-test, ANOVA, Pearson r
	Outcome must be Scale. Use non-parametric tests for Ordinal data.

	No significant outliers
	t-test, ANOVA, Pearson r
	Check boxplots in Explore. Outliers inflate variance and distort results.

	Expected cell counts
	Chi-square
	< 20% of cells should have expected count < 5. SPSS reports this as a footnote.



[bookmark: _bookmark41]Key statistical terms

	Term
	Definition

	p-value (Sig.)
	Probability of the observed result if the null hypothesis were true. Below .05 = conventionally significant.

	Null hypothesis (H0)
	Default assumption of no effect or no difference. Tests attempt to challenge this.

	Alternative hypothesis (H1)
	The claim being tested — that a difference or relationship exists.

	Type I error
	Rejecting H0 when it is true (false positive). Risk = alpha level (usually .05).

	Type II error
	Failing to reject H0 when it is false (false negative).

	Effect size
	Practical magnitude. Cohen's d (t-tests), eta-squared (ANOVA), r (correlation).

	Confidence interval
	Range within which the true population value likely falls (e.g. 95% CI).

	Statistical power
	Probability of detecting a real effect. Increases with larger sample size.

	Degrees of freedom (df)
	Values free to vary in the calculation. Related to sample size and number of groups.

	Pearson r
	Correlation coefficient for two scale variables. Ranges from -1 to +1.

	Scale variable
	Continuous/interval/ratio data (e.g. age, score, weight).

	Ordinal variable
	Ordered categories with unequal intervals (e.g. satisfaction rating, grade band).

	Nominal variable
	Unordered categories (e.g. gender, department, vehicle type).

	System-missing
	SPSS's own missing code — represented as a period (.) in Data View.

	User-missing
	A numeric code you define (e.g. 99) to indicate missing data.




[bookmark: _bookmark42]SPSS golden rules
· Always complete Variable View (Name, Label, Values, Measure) before entering data.
· Run descriptive statistics before any inferential test — know your data first.
· Check assumptions (normality, equal variances, outliers) before interpreting test results.
· Report effect sizes alongside p-values — significance alone is not enough.
· Use Paste instead of OK when learning — builds syntax knowledge automatically.
· Save your syntax file (.sps) so you can reproduce your analysis at any time.
· Always reset Data > Split File and Data > Select Cases after using them.
· Save your data (.sav) and output (.spv) files after every session.
Next steps after this course: explore independent-samples t-tests, factorial ANOVA, multiple regression, and reliability analysis (Cronbach's alpha).
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